Security update for tcpdump

SUSE Security Update: Security update for tcpdump
Announcement ID: SUSE-SU-2019:2674-1
Rating: important
References: #1068716 #1153098 #1153332
Cross-References: CVE-2017-16808 CVE-2018-10103 CVE-2018-10105 CVE-2018-14461 CVE-2018-14462 CVE-2018-14463 CVE-2018-14464 CVE-2018-14465 CVE-2018-14466 CVE-2018-14467 CVE-2018-14468 CVE-2018-14469 CVE-2018-14470 CVE-2018-14879 CVE-2018-14880 CVE-2018-14881 CVE-2018-14882 CVE-2018-16227 CVE-2018-16228 CVE-2018-16229 CVE-2018-16230 CVE-2018-16300 CVE-2018-16301 CVE-2018-16451 CVE-2018-16452 CVE-2019-1010220 CVE-2019-15166 CVE-2019-15167
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes 28 vulnerabilities is now available.

Description:

This update for tcpdump fixes the following issues:

  • CVE-2017-16808: Fixed a heap-based buffer over-read related to aoe_print and lookup_emem (bsc#1068716 bsc#1153098).
  • CVE-2018-10103: Fixed a mishandling of the printing of SMB data (bsc#1153098).
  • CVE-2018-10105: Fixed a mishandling of the printing of SMB data (bsc#1153098).
  • CVE-2018-14461: Fixed a buffer over-read in print-ldp.c:ldp_tlv_print (bsc#1153098).
  • CVE-2018-14462: Fixed a buffer over-read in print-icmp.c:icmp_print (bsc#1153098).
  • CVE-2018-14463: Fixed a buffer over-read in print-vrrp.c:vrrp_print (bsc#1153098).
  • CVE-2018-14464: Fixed a buffer over-read in print-lmp.c:lmp_print_data_link_subobjs (bsc#1153098).
  • CVE-2018-14465: Fixed a buffer over-read in print-rsvp.c:rsvp_obj_print (bsc#1153098).
  • CVE-2018-14466: Fixed a buffer over-read in print-rx.c:rx_cache_find (bsc#1153098).
  • CVE-2018-14467: Fixed a buffer over-read in print-bgp.c:bgp_capabilities_print (bsc#1153098).
  • CVE-2018-14468: Fixed a buffer over-read in print-fr.c:mfr_print (bsc#1153098).
  • CVE-2018-14469: Fixed a buffer over-read in print-isakmp.c:ikev1_n_print (bsc#1153098).
  • CVE-2018-14470: Fixed a buffer over-read in print-babel.c:babel_print_v2 (bsc#1153098).
  • CVE-2018-14879: Fixed a buffer overflow in the command-line argument parser (bsc#1153098).
  • CVE-2018-14880: Fixed a buffer over-read in the OSPFv3 parser (bsc#1153098).
  • CVE-2018-14881: Fixed a buffer over-read in the BGP parser (bsc#1153098).
  • CVE-2018-14882: Fixed a buffer over-read in the ICMPv6 parser (bsc#1153098).
  • CVE-2018-16227: Fixed a buffer over-read in the IEEE 802.11 parser in print-802_11.c for the Mesh Flags subfield (bsc#1153098).
  • CVE-2018-16228: Fixed a buffer over-read in the HNCP parser (bsc#1153098).
  • CVE-2018-16229: Fixed a buffer over-read in the DCCP parser (bsc#1153098).
  • CVE-2018-16230: Fixed a buffer over-read in the BGP parser in print-bgp.c:bgp_attr_print (bsc#1153098).
  • CVE-2018-16300: Fixed an unlimited recursion in the BGP parser that allowed denial-of-service by stack consumption (bsc#1153098).
  • CVE-2018-16301: Fixed a buffer overflow (bsc#1153332 bsc#1153098).
  • CVE-2018-16451: Fixed several buffer over-reads in print-smb.c:print_trans() for \MAILSLOT\BROWSE and \PIPE\LANMAN (bsc#1153098).
  • CVE-2018-16452: Fixed a stack exhaustion in smbutil.c:smb_fdata (bsc#1153098).
  • CVE-2019-15166: Fixed a bounds check in lmp_print_data_link_subobjs (bsc#1153098).
  • CVE-2019-15167: Fixed a vulnerability in VRRP (bsc#1153098).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2674=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-2674=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • tcpdump-4.9.2-3.9.1
    • tcpdump-debuginfo-4.9.2-3.9.1
    • tcpdump-debugsource-4.9.2-3.9.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • tcpdump-4.9.2-3.9.1
    • tcpdump-debuginfo-4.9.2-3.9.1
    • tcpdump-debugsource-4.9.2-3.9.1

References: