Security update for java-1_7_0-ibm

SUSE Security Update: Security update for java-1_7_0-ibm
Announcement ID: SUSE-SU-2019:13975-1
Rating: important
References: #1122293 #1122299
Cross-References: CVE-2018-11212 CVE-2019-2422
Affected Products:
  • SUSE Linux Enterprise Point of Sale 11-SP3

An update that fixes two vulnerabilities is now available.

Description:

This update for java-1_7_0-ibm to version 7.0.10.40 fixes the following issues:
Security issues fixed:

  • CVE-2019-2422: Fixed a memory disclosure in FileChannelImpl (bsc#1122293).
  • CVE-2018-11212: Fixed an issue in alloc_sarray function in jmemmgr.c (bsc#1122299).

More information: https://developer.ibm.com/javasdk/support/security-vulnerabilities/#IBM_Sec urity_Update_February_2019

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-java-1_7_0-ibm-13975=1

Package List:

  • SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
    • java-1_7_0-ibm-1.7.0_sr10.40-65.35.1
    • java-1_7_0-ibm-alsa-1.7.0_sr10.40-65.35.1
    • java-1_7_0-ibm-devel-1.7.0_sr10.40-65.35.1
    • java-1_7_0-ibm-jdbc-1.7.0_sr10.40-65.35.1
    • java-1_7_0-ibm-plugin-1.7.0_sr10.40-65.35.1

References: