Upstream information

CVE-2014-2532 at MITRE

Description

sshd in OpenSSH before 6.6 does not properly support wildcards on AcceptEnv lines in sshd_config, which allows remote attackers to bypass intended environment restrictions by using a substring located before a wildcard character.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  SUSE
Base Score 4.9
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity High
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1

Note from the SUSE Security Team

We think that this can be worked around by the administrator not using wildcards in the AcceptEnv parameters in sshd_config.

SUSE Bugzilla entries: 1074631 [RESOLVED / NORESPONSE], 869101 [RESOLVED / FIXED], 890850 [RESOLVED / FIXED], 915834 [RESOLVED], 916239 [RESOLVED], 996040 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Patchnames:
sledsp3-openssh
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Patchnames:
slessp3-openssh
SUSE Linux Enterprise Server 11 SP4
  • openssh >= 6.6p1-4.7
  • openssh-fips >= 6.6p1-4.7
SUSE Linux Enterprise Server 11-SECURITY
  • openssh-openssl1 >= 6.6p1-10.1
  • openssh-openssl1-helpers >= 6.6p1-10.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 openssh Unsupported
SLES for SAP Applications openssh Released
SLES-10-SP3 openssh Unsupported
SUSE Linux Enterprise Desktop 11 SP1 openssh Released
SUSE Linux Enterprise Desktop 11 SP2 openssh Released
SUSE Linux Enterprise Desktop 11 SP3 openssh Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search openssh Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS openssh Analysis
SUSE Linux Enterprise Micro 5.0 openssh Analysis
SUSE Linux Enterprise Micro 5.1 openssh Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP3 openssh Analysis
SUSE Linux Enterprise Module for Server Applications 15 SP3 openssh Analysis
SUSE Linux Enterprise Point of Service 11 SP3 openssh In progress
SUSE Linux Enterprise Server 11 SP1 openssh Released
SUSE Linux Enterprise Server 11 SP1 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP2 openssh Released
SUSE Linux Enterprise Server 11 SP2 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP2 for VMware openssh Released
SUSE Linux Enterprise Server 11 SP3 openssh Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP3 for VMware openssh Released
SUSE Linux Enterprise Server 12 SP4 LTSS openssh Analysis
SUSE Linux Enterprise Server BCL 12 SP2 openssh Analysis
SUSE Linux Enterprise Server BCL 12 SP3 openssh Analysis
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openssh Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssh Not affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 openssh Released
Security Module for SUSE Linux Enterprise 11 openssh-openssl1 In progress