CVE-2014-2538

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-2538 at MITRE

Description

Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)

SUSE information

SUSE Bugzilla entry: 869162

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1
Builds
SAT Patch Nr: 9098
SUSE Lifecycle Management Server 1.3
SUSE Studio Onsite 1.3
WebYaST 1.3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1
Builds
SAT Patch Nr: 9097
openSUSE 12.3
  • rubygem-rack-ssl >= 1.3.2-6.4.1
  • rubygem-rack-ssl-doc >= 1.3.2-6.4.1
Patchnames:
openSUSE-2014-293
openSUSE 13.1
  • rubygem-rack-ssl >= 1.3.3-2.4.1
  • rubygem-rack-ssl-doc >= 1.3.3-2.4.1
Patchnames:
openSUSE-2014-293