SUSE Support

Here When You Need Us

SUSE Manager sync fails on several repo's towards SUSE Customer Center (according to the GUI)

This document (000021202) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager Server 4.3

Situation

After synchronizing from within WebUI or via command line:

mgr-sync -v -d3 refresh --refresh-channels

Some channels are marked as "sync failed".

Resolution

The cache for those channels needs to be recreated:
spacecmd softwarechannel_regenerateyumcache <channel_label>
Executed on all the channels needed, this resolves the problem.

Cause

The Web UI relies on the presence of metadata files for the channel on the server to consider it synchronized. You can use the following command to check for the presence of repomd.xml file in the specified directory:
 ls /var/cache/rhn/repodata/<channel_label>

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021202
  • Creation Date: 12-Sep-2023
  • Modified Date:12-Oct-2023
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.