SUSE Support

Here When You Need Us

CPU Steal Time Accounting for VMware guest

This document (000021197) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server 12

Situation

CPU Steal Time Account is generally not enabled by default in VMware guests.
Steal time is the amount of CPU time needed by a guest virtual machine that is not provided by the host. Steal time occurs when the host allocates this CPU time elsewhere, for example, to another guest.

Resolution

SLES15 has the kernel commits to enable this feature, however, VMware vmx file changes are also required.

The VM configuration option is needed:  stealclock.enable = "TRUE"

SLES12 SP5 kernel version 4.12.14-122.176.1 (released Sept 2023) and above have the commits available.

https://lists.suse.com/pipermail/sle-updates/2023-September/031564.html
  * x86/vmware: add a header file for hypercall definitions (bsc#1210327).
  * x86/vmware: add steal time clock support for vmware guests (bsc#1210327).
  * x86/vmware: enable steal time accounting (bsc#1210327).
  * x86/vmware: update platform detection code for vmcall/vmmcall hypercalls
    (bsc#1210327).

 

Cause

CPU Steal Time Account is not enabled by default in VMware guests.

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021197
  • Creation Date: 20-Sep-2023
  • Modified Date:20-Sep-2023
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.