SUSE Support

Here When You Need Us

Object Gateway dashboard access fails with error 404

This document (000020620) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 7

Situation

When attempting to access the Object Gateway from the Dashboard this fails with the following error:
 
RGW REST API failed request with status code 404

In the Manager log the error will be logged as:
 
<$hostname> conmon[190959]: debug 2022-03-17T13:11:31.702+0000 7fe02f440700  0 [dashboard ERROR rest_client] RGW REST API failed GET req status: 404

Resolution

Re-add the ADMIN Rados Gateway API:
 
ceph config set client.rgw rgw_enable_apis "s3, s3website, swift, swift_auth, admin, sts, iam, pubsub"

Then restart the Rados Gateway Services:
ceph orch restart rgw.<insert_realm>.<insert_zone>

Cause

The "admin" API was at some point removed from the list as this is by default enabled.

Additional Information

To see the currently assigned APIs execute:
 
ceph config get client.rgw rgw_enable_apis

The default set of APIs are:
 
s3, s3website, swift, swift_auth, admin, sts, iam, pubsub

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020620
  • Creation Date: 17-Mar-2022
  • Modified Date:17-Mar-2022
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.