SUSE Support

Here When You Need Us

Entry "CALLING CRM: ... rc=256" in HANA trace after upgrading SAPHanaSR-ScaleOut

This document (000020599) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server for SAP Applications 15
SUSE Linux Enterprise Server for SAP Applications 12

Situation

After upgrading SAPHanaSR-ScaleOut to 0.180 or newer, the initialisation of HADR provider hook script SAPHanaSR.py leads to an info message in HANA master nameserver tracefiles. 
nameserver_vhupddb01b.30201.009.trc:[22606]{-1}[-1/-1] 2022-02-18 05:38:56.147578  a_dr_SAPHanaSR  SAPHanaSR.py(00115) : SAPHanaSR.srConnectionChanged() CALLING CRM: <sudo /usr/sbin/crm_attribute -n hana_upd_gsh -v 1.0 -l reboot> rc=256

Despite the return code "rc=256" the hook script gets loaded and works fine.
The observed effect does not affect functions of the hook script SAPHanaSR.py or the overall SAPHanaSR-ScaleOut solution. This is shown in HANA nameserver tracefiles as well:
nameserver_vhupddb01b.30201.009.trc:[22606]{-1}[-1/-1] 2022-02-18 05:38:57.732616 i ha_dr_SAPHanaSR  SAPHanaSR.py(00135) : SAPHanaSR CALLING CRM: <sudo /usr/sbin/crm_attribute -n hana_upd_glob_srHook -v SOK -t crm_config -s SAPHanaSR> rc=0

Resolution

To avoid the message, an appropriate sudoers rule can be applied.
Lowercase-SID in the example is "upd", node is "suse11". The rule is added to the drop-in file "SAPHanaSR":
# vi /etc/sudoers.d/SAPHanaSR
...
updadm ALL=(ALL) NOPASSWD: /usr/sbin/crm_attribute -n hana_upd_gsh -v * -l reboot -t crm_config -s SAPHanaSR

Check the result:
# sudo -U updadm -l
Matching Defaults entries for updadm on suse11:
    always_set_home, secure_path=/usr/sbin\:/usr/bin\:/sbin\:/bin, env_reset, env_keep="LANG LC_ADDRESS LC_CTYPE LC_COLLATE LC_IDENTIFICATION LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER
    LC_TELEPHONE LC_ATIME LC_ALL LANGUAGE LINGUAS XDG_SESSION_COOKIE", !insults, targetpw

User updadm may run the following commands on suse11:
 (ALL) NOPASSWD: /usr/sbin/crm_attribute -n hana_upd_glob_srHook -v * -t crm_config -s SAPHanaSR
 (ALL) NOPASSWD: /usr/sbin/crm_attribute -n hana_upd_gsh -v * -l reboot -t crm_config -s SAPHanaSR


Alternatively the existing sudoers rule for the hana_<sid>_glob_srHook attribute can be adapted to cover the new hana_<sid>_gsh as well.
Please see manual pages SAPHanaSR.py(7), sudoers(5) and sudo(8) for details.

Cause

Since SAPHanaSR-ScaleOut 0.180 the package allows HANA scale-out multi-target setups. Therefor it introduces new Linux cluster CIB attributes.

To ensure virtually absolute backward compatibility, the package now contains two HADR provider hook scripts. An old one and an new one. On the other hand, a smooth upgrade procedure from to HANA multi-target replication is needed. Therefor auxiliary CIB attributes have been introduced for SAPHanaSR.py.

On initialisation of the hook script SAPHanaSR.py, the upgraded script tries writing its new auxiliary attribute hana_<sid>_gsh into the CIB.

If customers upgrade the package, but do not change anything, everything works fine. Just the auxiliary attribute can not be written. Therefor HANA writes an info message into its tracefiles on hook script initialisation. This does not affect the hook script functionality.

Please see manual pages SAPHanaSR.py(7) and SAPHanaSR-showAttr(8) for details.

Additional Information

SAPHanaSR.py(7)
SAPHanaSR-showAttr(8)
sudoers(5)
sudo(8)

Please refer to SUSE and SAP product docu for pre-requisites of HA for SAP HANA scale-out multi-target system replication.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020599
  • Creation Date: 07-Mar-2022
  • Modified Date:07-Mar-2022
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.