SUSE Support

Here When You Need Us

Upgrade from Service Pack 1 to Service Pack 2 fails at initial reboot on IBM System z

This document (7004163) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 2 for IBM System z

Situation

The original installation ISO image for SUSE Linux Enterprise Server 11 Service Pack 2 creates an initial RAM disk (initrd) that may fail when booting from a zFCP SCSI device.

Resolution

The installation media DVD 1 has been replaced with an updated version that creates a properly working initrd for this case. The md5sum of the new image is b54c6a6155c598216ce714155bb788b1.

Cause

The initrd scripts of the original image sometimes fail to set certain devices online.

Additional Information

When updating by using the old image (md5sum c611ea5e7f1d356ccb46d7efc1b4bece) of DVD1, the boot process of the updated system may stop with error messages indicating that disk devices could not be found and the boot process exiting to /bin/sh.

To repair a system at this stage, the zFCP device needs to be set online manually

  echo 1 > /sys/bus/ccw/devices/$ZFCPCCW/online
  exit

($ZFCPCCW needs to be replaced with the CCW of the zFCP device containing the failing filesystem, for example 0.0.1ff0)

After the system finishes booting, the statement

  /sbin/udevadm trigger --type=subsystems --action=add

needs to be added to the file
/lib/mkinitrd/scripts/boot-udev.sh near the end, but just before the
wait_for_events statement. The last lines of the file should look like this:

  /sbin/udevd --daemon
  /sbin/udevadm trigger --action=add
  /sbin/udevadm trigger --type=subsystems --action=add
  wait_for_events

Finally, the corrected initrd needs to be build and the boot loader refreshed:

  mkinitrd
  zipl

Afterwards, the system can be rebooted.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7004163
  • Creation Date: 13-Apr-2012
  • Modified Date:12-Oct-2022
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.