Upstream information

CVE-2021-22880 at MITRE

Description

The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1182169 [NEW], 1188335 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-activerecord-5_1 >= 5.1.4-5.3.3
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2021-3634
SUSE Linux Enterprise High Availability 15 SP2
  • ruby2.5-rubygem-activerecord-5_1 >= 5.1.4-5.3.3
Patchnames:
SUSE-SLE-Product-HA-15-SP2-2021-3634
SUSE Linux Enterprise High Availability 15 SP3
  • ruby2.5-rubygem-activerecord-5_1 >= 5.1.4-5.3.3
Patchnames:
SUSE-SLE-Product-HA-15-SP3-2021-3634
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-activerecord-5_1 >= 5.1.4-5.3.3
Patchnames:
SUSE-SLE-Product-HA-15-2021-3634
SUSE OpenStack Cloud Crowbar 8
  • ruby2.1-rubygem-activerecord-4_2 >= 4.2.9-6.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-3267
SUSE OpenStack Cloud Crowbar 9
  • ruby2.1-rubygem-activerecord-4_2 >= 4.2.9-6.6.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-3267
openSUSE Leap 15.2
  • ruby2.5-rubygem-activerecord-5_1 >= 5.1.4-lp152.4.3.1
Patchnames:
openSUSE-2021-1468
openSUSE Leap 15.3
  • ruby2.5-rubygem-activerecord-5_1 >= 5.1.4-5.3.3
Patchnames:
openSUSE-SLE-15.3-2021-3634
openSUSE Tumbleweed
  • ruby2.7-rubygem-activerecord-5.2 >= 5.2.6-1.2
  • ruby2.7-rubygem-activerecord-6.0 >= 6.0.4-1.2
  • ruby3.0-rubygem-activerecord-5.2 >= 5.2.6-1.2
  • ruby3.0-rubygem-activerecord-6.0 >= 6.0.4-1.2
Patchnames:
openSUSE Tumbleweed GA ruby2.7-rubygem-activerecord-5.2-5.2.6-1.2
openSUSE Tumbleweed GA ruby2.7-rubygem-activerecord-6.0-6.0.4-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 15 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Availability Extension 15 SP3 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Performance Computing 15 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server 15 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server 15 SP1 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server 15 SP2 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server 15 SP3 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 rubygem-activerecord-3_2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Storage 6 rubygem-activerecord-5_1 Released
SUSE Linux Enterprise Storage 7 rubygem-activerecord-5_1 Released
SUSE Manager Proxy 4.0 rubygem-activerecord-5_1 Released
SUSE Manager Proxy 4.1 rubygem-activerecord-5_1 Released
SUSE Manager Proxy 4.2 rubygem-activerecord-5_1 Released
SUSE Manager Server 4.0 rubygem-activerecord-5_1 Released
SUSE Manager Server 4.1 rubygem-activerecord-5_1 Released
SUSE Manager Server 4.2 rubygem-activerecord-5_1 Released
SUSE OpenStack Cloud 7 rubygem-activerecord-4_2 Unsupported
SUSE OpenStack Cloud Crowbar 8 rubygem-activerecord-4_2 Released
SUSE OpenStack Cloud Crowbar 9 rubygem-activerecord-4_2 Released
WebYaST for SLE-11 rubygem-activerecord-3_2 Not affected