Upstream information

CVE-2021-22879 at MITRE

Description

Nextcloud Desktop Client prior to 3.1.3 is vulnerable to resource injection by way of missing validation of URLs, allowing a malicious server to execute remote commands. User interaction is needed for exploitation.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 6.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1184770 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.2
  • caja-extension-nextcloud >= 3.1.3-lp152.2.6.1
  • libnextcloudsync-devel >= 3.1.3-lp152.2.6.1
  • libnextcloudsync0 >= 3.1.3-lp152.2.6.1
  • nautilus-extension-nextcloud >= 3.1.3-lp152.2.6.1
  • nemo-extension-nextcloud >= 3.1.3-lp152.2.6.1
  • nextcloud-desktop >= 3.1.3-lp152.2.6.1
  • nextcloud-desktop-doc >= 3.1.3-lp152.2.6.1
  • nextcloud-desktop-dolphin >= 3.1.3-lp152.2.6.1
  • nextcloud-desktop-lang >= 3.1.3-lp152.2.6.1
Patchnames:
openSUSE-2021-577
openSUSE Tumbleweed
  • caja-extension-nextcloud >= 3.3.4-1.1
  • libnextcloudsync-devel >= 3.3.4-1.1
  • libnextcloudsync0 >= 3.3.4-1.1
  • nautilus-extension-nextcloud >= 3.3.4-1.1
  • nemo-extension-nextcloud >= 3.3.4-1.1
  • nextcloud-desktop >= 3.3.4-1.1
  • nextcloud-desktop-doc >= 3.3.4-1.1
  • nextcloud-desktop-dolphin >= 3.3.4-1.1
  • nextcloud-desktop-lang >= 3.3.4-1.1
Patchnames:
openSUSE Tumbleweed GA caja-extension-nextcloud-3.3.4-1.1