Upstream information

CVE-2021-22881 at MITRE

Description

The Host Authorization middleware in Action Pack before 6.1.2.1, 6.0.3.5 suffers from an open redirect vulnerability. Specially crafted `Host` headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website. Impacted applications will have allowed hosts with a leading dot. When an allowed host contains a leading dot, a specially crafted `Host` header can be used to redirect to a malicious website.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.1 6.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Changed Changed
Confidentiality Impact Low None
Integrity Impact Low Low
Availability Impact None Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1182160 [RESOLVED / INVALID], 1185772 [RESOLVED / FIXED], 1189627 [RESOLVED / FIXED], 1193764 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ruby2.7-rubygem-actionpack-6.0 >= 6.0.4-1.2
  • ruby3.0-rubygem-actionpack-6.0 >= 6.0.4-1.2
Patchnames:
openSUSE Tumbleweed GA ruby2.7-rubygem-actionpack-6.0-6.0.4-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 15 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Server 15 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Server 15 SP1 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Server 15 SP2 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 rubygem-actionpack-3_2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Storage 6 rubygem-actionpack-5_1 Not affected
SUSE Linux Enterprise Storage 7 rubygem-actionpack-5_1 Not affected
SUSE Manager Proxy 4.0 rubygem-actionpack-5_1 Not affected
SUSE Manager Proxy 4.1 rubygem-actionpack-5_1 Not affected
SUSE Manager Server 4.0 rubygem-actionpack-5_1 Not affected
SUSE Manager Server 4.1 rubygem-actionpack-5_1 Not affected
SUSE OpenStack Cloud 7 rubygem-actionpack-4_2 Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-actionpack-4_2 Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-actionpack-4_2 Not affected
WebYaST for SLE-11 rubygem-actionpack-3_2 Not affected