Upstream information

CVE-2020-28020 at MITRE

Description

Exim 4 before 4.92 allows Integer Overflow to Buffer Overflow, in which an unauthenticated remote attacker can execute arbitrary code by leveraging the mishandling of continuation lines during header-length restriction.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1185631 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP1
  • exim >= 4.94.2-bp151.2.4.1
  • eximon >= 4.94.2-bp151.2.4.1
  • eximstats-html >= 4.94.2-bp151.2.4.1
  • libspf2-2 >= 1.2.10-bp151.4.1
  • libspf2-2-debuginfo >= 1.2.10-bp151.4.1
  • libspf2-debuginfo >= 1.2.10-bp151.4.1
  • libspf2-debugsource >= 1.2.10-bp151.4.1
  • libspf2-devel >= 1.2.10-bp151.4.1
  • libspf2-tools >= 1.2.10-bp151.4.1
  • libspf2-tools-debuginfo >= 1.2.10-bp151.4.1
Patchnames:
openSUSE-2021-753
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • exim >= 4.94.2-bp152.6.4.1
  • eximon >= 4.94.2-bp152.6.4.1
  • eximstats-html >= 4.94.2-bp152.6.4.1
  • libspf2-2 >= 1.2.10-bp152.5.1
  • libspf2-2-debuginfo >= 1.2.10-bp152.5.1
  • libspf2-debuginfo >= 1.2.10-bp152.5.1
  • libspf2-debugsource >= 1.2.10-bp152.5.1
  • libspf2-devel >= 1.2.10-bp152.5.1
  • libspf2-tools >= 1.2.10-bp152.5.1
  • libspf2-tools-debuginfo >= 1.2.10-bp152.5.1
Patchnames:
openSUSE-2021-754
openSUSE Leap 15.2
  • exim >= 4.94.2-lp152.8.3.1
  • exim-debuginfo >= 4.94.2-lp152.8.3.1
  • exim-debugsource >= 4.94.2-lp152.8.3.1
  • eximon >= 4.94.2-lp152.8.3.1
  • eximon-debuginfo >= 4.94.2-lp152.8.3.1
  • eximstats-html >= 4.94.2-lp152.8.3.1
Patchnames:
openSUSE-2021-677