Upstream information

CVE-2019-9494 at MITRE

Description

The implementations of SAE in hostapd and wpa_supplicant are vulnerable to side channel attacks as a result of observable timing differences and cache access patterns. An attacker may be able to gain leaked information from a side channel attack that can be used for full password recovery. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.7 are affected.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.9
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
Access Vector Network Adjacent Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None Low
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1131291 [IN_PROGRESS], 1131868 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • wpa_supplicant >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-3380
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • wpa_supplicant >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-3380
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • wpa_supplicant >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2020-3380
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • wpa_supplicant >= 2.9-4.20.1
  • wpa_supplicant-gui >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-3380
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • wpa_supplicant >= 2.9-4.20.1
  • wpa_supplicant-gui >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-3380
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • wpa_supplicant >= 2.9-23.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-3424
SUSE Linux Enterprise Server 15-LTSS
  • wpa_supplicant >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-3380
SUSE Linux Enterprise Server for SAP Applications 15
  • wpa_supplicant >= 2.9-4.20.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-3380
openSUSE Leap 15.1
  • hostapd >= 2.9-lp151.4.3.1
  • hostapd-debuginfo >= 2.9-lp151.4.3.1
  • hostapd-debugsource >= 2.9-lp151.4.3.1
  • wpa_supplicant >= 2.9-lp151.5.10.1
  • wpa_supplicant-debuginfo >= 2.9-lp151.5.10.1
  • wpa_supplicant-debugsource >= 2.9-lp151.5.10.1
  • wpa_supplicant-gui >= 2.9-lp151.5.10.1
  • wpa_supplicant-gui-debuginfo >= 2.9-lp151.5.10.1
Patchnames:
openSUSE-2020-2053
openSUSE-2020-222
openSUSE Leap 15.2
  • wpa_supplicant >= 2.9-lp152.8.3.1
  • wpa_supplicant-debuginfo >= 2.9-lp152.8.3.1
  • wpa_supplicant-debugsource >= 2.9-lp152.8.3.1
  • wpa_supplicant-gui >= 2.9-lp152.8.3.1
  • wpa_supplicant-gui-debuginfo >= 2.9-lp152.8.3.1
Patchnames:
openSUSE-2020-2059


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications wpa_supplicant Not affected
SUSE Linux Enterprise 15 Module for Basesystem wpa_supplicant Affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem wpa_supplicant Released
SUSE Linux Enterprise 15-SP2 Module for Basesystem wpa_supplicant Released
SUSE Linux Enterprise Desktop 12 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Desktop 12 SP4 wpa_supplicant Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 wpa_supplicant Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP3 LTSS wpa_supplicant Not affected
SUSE Linux Enterprise Server 11 SP4 wpa_supplicant Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS wpa_supplicant Not affected
SUSE Linux Enterprise Server 12 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP1 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP2 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP5 wpa_supplicant Released
SUSE Linux Enterprise Server for SAP Applications 12 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 wpa_supplicant Released