Upstream information

CVE-2018-20748 at MITRE

Description

LibVNC before 0.9.12 contains multiple heap out-of-bounds write vulnerabilities in libvncclient/rfbproto.c. The fix for CVE-2018-20019 was incomplete.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1120118 [RESOLVED / FIXED], 1123823 [RESOLVED / FIXED], 1155442 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-Storage-4-2019-313
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libvncclient0 >= 0.9.9-17.14.1
  • libvncserver0 >= 0.9.9-17.14.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • LibVNCServer >= 0.9.10-4.6.1
  • LibVNCServer-devel >= 0.9.10-4.6.1
  • libvncserver0 >= 0.9.10-4.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-283
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • LibVNCServer >= 0.9.10-4.6.1
  • libvncserver0 >= 0.9.10-4.6.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-283
SUSE Linux Enterprise Point of Sale 11 SP3
  • LibVNCServer >= 0.9.1-160.9.1
Patchnames:
sleposp3-LibVNCServer-13952
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-313
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • LibVNCServer >= 0.9.1-160.9.1
Patchnames:
slessp4-LibVNCServer-13952
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-313
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-313
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-313
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-313
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-313
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-313
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SERVER-12-2019-313
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-313
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-313
SUSE Linux Enterprise Software Development Kit 11 SP4
  • LibVNCServer >= 0.9.1-160.9.1
  • LibVNCServer-devel >= 0.9.1-160.9.1
Patchnames:
sdksp4-LibVNCServer-13952
SUSE Linux Enterprise Software Development Kit 12 SP3
  • LibVNCServer >= 0.9.9-17.11.1
  • LibVNCServer-devel >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-313
SUSE Linux Enterprise Software Development Kit 12 SP4
  • LibVNCServer >= 0.9.9-17.11.1
  • LibVNCServer-devel >= 0.9.9-17.11.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-313
SUSE Linux Enterprise Software Development Kit 12 SP5
  • LibVNCServer-devel >= 0.9.9-17.14.1
SUSE Linux Enterprise Workstation Extension 15 SP1
  • libvncclient0 >= 0.9.10-4.9.1
SUSE Linux Enterprise Workstation Extension 15
  • LibVNCServer >= 0.9.10-4.6.1
  • libvncclient0 >= 0.9.10-4.6.1
Patchnames:
SUSE-SLE-Product-WE-15-2019-283
SUSE OpenStack Cloud 7
  • LibVNCServer >= 0.9.9-17.11.1
  • libvncclient0 >= 0.9.9-17.11.1
  • libvncserver0 >= 0.9.9-17.11.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-313
openSUSE Leap 15.0
  • LibVNCServer >= 0.9.10-lp150.3.6.1
  • LibVNCServer-debugsource >= 0.9.10-lp150.3.6.1
  • LibVNCServer-devel >= 0.9.10-lp150.3.6.1
  • libvncclient0 >= 0.9.10-lp150.3.6.1
  • libvncclient0-debuginfo >= 0.9.10-lp150.3.6.1
  • libvncserver0 >= 0.9.10-lp150.3.6.1
  • libvncserver0-debuginfo >= 0.9.10-lp150.3.6.1
Patchnames:
openSUSE-2019-196
openSUSE Leap 42.3
  • LibVNCServer >= 0.9.9-16.9.1
  • LibVNCServer-debugsource >= 0.9.9-16.9.1
  • LibVNCServer-devel >= 0.9.9-16.9.1
  • libvncclient0 >= 0.9.9-16.9.1
  • libvncclient0-debuginfo >= 0.9.9-16.9.1
  • libvncserver0 >= 0.9.9-16.9.1
  • libvncserver0-debuginfo >= 0.9.9-16.9.1
  • linuxvnc >= 0.9.9-16.9.1
  • linuxvnc-debuginfo >= 0.9.9-16.9.1
Patchnames:
openSUSE-2019-200


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications LibVNCServer Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 LibVNCServer Released
SUSE Linux Enterprise High Performance Computing 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Server 11 SP1 LibVNCServer Released
SUSE Linux Enterprise Server 11 SP3 LibVNCServer Released
SUSE Linux Enterprise Server 11 SP3 LTSS LibVNCServer Affected
SUSE Linux Enterprise Server 11 SP4 LibVNCServer Released
SUSE Linux Enterprise Server 12 LTSS LibVNCServer Released
SUSE Linux Enterprise Server 12 SP1 LTSS LibVNCServer Released
SUSE Linux Enterprise Server 12 SP2 LTSS LibVNCServer Released
SUSE Linux Enterprise Server 12 SP3 LibVNCServer Released
SUSE Linux Enterprise Server 12 SP4 LibVNCServer Released
SUSE Linux Enterprise Server 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 LibVNCServer Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Software Development Kit 11 SP4 LibVNCServer Released
SUSE Linux Enterprise Software Development Kit 12 SP3 LibVNCServer Released
SUSE Linux Enterprise Software Development Kit 12 SP4 LibVNCServer Released
SUSE Linux Enterprise Workstation Extension 15 LibVNCServer Released
SUSE Linux Enterprise Workstation Extension 15 SP2 LibVNCServer Affected