Upstream information

CVE-2017-17426 at MITRE

Description

The malloc function in the GNU C Library (aka glibc or libc6) 2.26 could return a memory block that is too small if an attempt is made to allocate an object whose size is close to SIZE_MAX, potentially leading to a subsequent heap overflow. This occurs because the per-thread cache (aka tcache) feature enables a code path that lacks an integer overflow check.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.1
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1071479 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • glibc >= 2.26-13.19.1
  • glibc-32bit >= 2.26-13.19.1
  • glibc-devel >= 2.26-13.19.1
  • glibc-extra >= 2.26-13.19.1
  • glibc-i18ndata >= 2.26-13.19.1
  • glibc-info >= 2.26-13.19.1
  • glibc-locale >= 2.26-13.19.1
  • glibc-locale-32bit >= 2.26-8.21
  • glibc-locale-base >= 2.26-13.19.1
  • glibc-profile >= 2.26-13.19.1
  • nscd >= 2.26-13.19.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • glibc >= 2.26-13.48.1
  • glibc-32bit >= 2.26-13.48.1
  • glibc-devel >= 2.26-13.48.1
  • glibc-extra >= 2.26-13.48.1
  • glibc-i18ndata >= 2.26-13.48.1
  • glibc-info >= 2.26-13.48.1
  • glibc-locale >= 2.26-13.48.1
  • glibc-locale-32bit >= 2.26-8.21
  • glibc-locale-base >= 2.26-13.48.1
  • glibc-locale-base-32bit >= 2.26-13.48.1
  • glibc-profile >= 2.26-13.48.1
  • nscd >= 2.26-13.48.1
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • glibc >= 2.31-7.30
  • glibc-32bit >= 2.31-7.20
  • glibc-devel >= 2.31-7.30
  • glibc-extra >= 2.31-7.30
  • glibc-i18ndata >= 2.31-7.30
  • glibc-info >= 2.31-7.30
  • glibc-lang >= 2.31-7.30
  • glibc-locale >= 2.31-7.30
  • glibc-locale-32bit >= 2.26-13.8.1
  • glibc-locale-base >= 2.31-7.30
  • glibc-locale-base-32bit >= 2.31-7.20
  • glibc-profile >= 2.31-7.30
  • nscd >= 2.31-7.30
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-11.8
  • glibc-32bit >= 2.26-11.8
  • glibc-devel >= 2.26-11.8
  • glibc-extra >= 2.26-11.8
  • glibc-i18ndata >= 2.26-11.8
  • glibc-info >= 2.26-11.8
  • glibc-locale >= 2.26-11.8
  • glibc-locale-32bit >= 2.26-11.8
  • glibc-profile >= 2.26-11.8
  • nscd >= 2.26-11.8
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • glibc-devel-32bit >= 2.26-8.21
  • glibc-devel-static >= 2.26-13.19.1
  • glibc-utils >= 2.26-13.19.1
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • glibc-devel-32bit >= 2.26-13.48.1
  • glibc-devel-static >= 2.26-13.48.1
  • glibc-utils >= 2.26-13.48.1
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • glibc-devel-32bit >= 2.31-7.20
  • glibc-devel-static >= 2.31-7.30
  • glibc-utils >= 2.31-7.1
SUSE Linux Enterprise Module for Development Tools 15
  • glibc-devel-32bit >= 2.26-11.8
  • glibc-devel-static >= 2.26-11.8
  • glibc-utils >= 2.26-11.8
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.10.13
  • glibc-32bit >= 2.26-lp150.10.13
  • glibc-extra >= 2.26-lp150.10.13
  • glibc-locale >= 2.26-lp150.10.13
  • glibc-locale-32bit >= 2.26-lp150.10.13
  • nscd >= 2.26-lp150.10.13
Patchnames:
openSUSE Leap 15.0 GA glibc-2.26-lp150.10.13
openSUSE Tumbleweed
  • glibc >= 2.34-1.2
  • glibc-devel >= 2.34-1.2
  • glibc-devel-static >= 2.34-1.2
  • glibc-extra >= 2.34-1.2
  • glibc-html >= 2.34-1.2
  • glibc-i18ndata >= 2.34-1.2
  • glibc-info >= 2.34-1.2
  • glibc-lang >= 2.34-1.2
  • glibc-locale >= 2.34-1.2
  • glibc-locale-base >= 2.34-1.2
  • glibc-profile >= 2.34-1.2
  • nscd >= 2.34-1.2
Patchnames:
openSUSE Tumbleweed GA glibc-2.34-1.2


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration glibc Not affected
SUSE CaaS Platform 4.0 glibc Already fixed
SUSE Container as a Service Platform 1.0 glibc Affected
SUSE Container as a Service Platform 2.0 glibc Not affected
SUSE Enterprise Storage 6 glibc Already fixed
SUSE Linux Enterprise Desktop 12 SP2 glibc Affected
SUSE Linux Enterprise Desktop 12 SP3 glibc Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS glibc Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS glibc Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS glibc Already fixed
SUSE Linux Enterprise Micro 5.0 glibc Already fixed
SUSE Linux Enterprise Micro 5.1 glibc Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP2 glibc Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 glibc Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP2 glibc Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP3 glibc Analysis
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4 glibc Not affected
SUSE Linux Enterprise Server 12 SP2 glibc Not affected
SUSE Linux Enterprise Server 12 SP3 glibc Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS glibc Analysis
SUSE Linux Enterprise Server 15 ESPOS glibc Already fixed
SUSE Linux Enterprise Server 15 LTSS glibc Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS glibc Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 glibc Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 glibc Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 glibc Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 glibc Not affected
SUSE Manager Proxy 4.0 glibc Already fixed
SUSE Manager Retail Branch Server 4.0 glibc Already fixed
SUSE Manager Server 4.0 glibc Already fixed