Upstream information

CVE-2014-2532 at MITRE

Description

sshd in OpenSSH before 6.6 does not properly support wildcards on AcceptEnv lines in sshd_config, which allows remote attackers to bypass intended environment restrictions by using a substring located before a wildcard character.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None

Note from the SUSE Security Team

We think that this can be worked around by the administrator not using wildcards in the AcceptEnv parameters in sshd_config.

SUSE Bugzilla entries: 1074631 [IN_PROGRESS], 869101 [RESOLVED / FIXED], 890850 [RESOLVED / FIXED], 915834 [RESOLVED], 916239 [RESOLVED], 996040 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Patchnames:
sledsp3-openssh
SUSE Linux Enterprise Server 11 SP3
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Patchnames:
slessp3-openssh
SUSE Linux Enterprise Server 11 SP4
  • openssh >= 6.6p1-4.7
  • openssh-fips >= 6.6p1-4.7
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA openssh
SUSE Linux Enterprise Server 11-SECURITY
  • openssh-openssl1 >= 6.6p1-10.1
  • openssh-openssl1-helpers >= 6.6p1-10.1
Patchnames:
SUSE Linux Enterprise Server 11-SECURITY GA openssh-openssl1
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Patchnames:
slessp3-openssh
SUSE Linux Enterprise Server for VMWare 11 SP3
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Patchnames:
slessp3-openssh
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • openssh >= 6.2p2-0.13.1
  • openssh-askpass >= 6.2p2-0.13.1
  • openssh-askpass-gnome >= 6.2p2-0.13.1
Builds
SAT Patch Nr: 9357


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 openssh Released
SUSE Linux Enterprise Desktop 11 SP1 openssh Released
SUSE Linux Enterprise Desktop 11 SP2 openssh Released
SUSE Linux Enterprise Desktop 11 SP3 openssh Released
SUSE Linux Enterprise Server 10 SP3 openssh Released
SUSE Linux Enterprise Server 11 SP1 openssh Released
SUSE Linux Enterprise Server 11 SP1 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP2 openssh Released
SUSE Linux Enterprise Server 11 SP2 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP3 openssh Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 openssh Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 openssh Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssh Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 openssh Released
SUSE Linux Enterprise Server for VMWare 11 SP2 openssh Released
SUSE Linux Enterprise Server for VMWare 11 SP3 openssh Released