Upstream information

CVE-2012-0866 at MITRE

Description

CREATE TRIGGER in PostgreSQL 8.3.x before 8.3.18, 8.4.x before 8.4.11, 9.0.x before 9.0.7, and 9.1.x before 9.1.3 does not properly check the execute permission for trigger functions marked SECURITY DEFINER, which allows remote authenticated users to execute otherwise restricted triggers on arbitrary data by installing the trigger on an attacker-owned table.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.52
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 701489 [RESOLVED / FIXED], 749299 [RESOLVED / FIXED], 749301 [RESOLVED / FIXED], 749303 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libecpg6 >= 9.3.5-2.3
  • libpq5 >= 9.3.5-2.3
  • libpq5-32bit >= 9.3.5-2.3
  • postgresql93 >= 9.3.5-2.24
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libecpg6
SUSE Linux Enterprise Desktop 12 SP1
  • libecpg6 >= 9.4.5-4.1
  • libpq5 >= 9.4.5-4.1
  • libpq5-32bit >= 9.4.5-4.1
  • postgresql94 >= 9.4.5-4.5
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libecpg6
SUSE Linux Enterprise Desktop 12 SP2
  • libecpg6 >= 9.4.9-14.1
  • libpq5 >= 9.4.9-14.1
  • libpq5-32bit >= 9.4.9-14.1
  • postgresql94 >= 9.4.9-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libecpg6
SUSE Linux Enterprise Server 12 SP2
  • libecpg6 >= 9.4.9-14.1
  • libecpg6-debuginfo >= 9.4.9-14.1
  • libpq5 >= 9.4.9-14.1
  • libpq5-32bit >= 9.4.9-14.1
  • libpq5-debuginfo >= 9.4.9-14.1
  • libpq5-debuginfo-32bit >= 9.4.9-14.1
  • postgresql94 >= 9.4.9-14.1
  • postgresql94-contrib >= 9.4.9-14.1
  • postgresql94-contrib-debuginfo >= 9.4.9-14.1
  • postgresql94-debuginfo >= 9.4.9-14.1
  • postgresql94-debugsource >= 9.4.9-14.1
  • postgresql94-docs >= 9.4.9-14.1
  • postgresql94-libs-debugsource >= 9.4.9-14.1
  • postgresql94-server >= 9.4.9-14.1
  • postgresql94-server-debuginfo >= 9.4.9-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libecpg6
SUSE Linux Enterprise Server 12 SP2 GA postgresql94-debuginfo
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • postgresql-devel >= 8.3.18-0.3.1
Builds
SAT Patch Nr: 6023
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • postgresql >= 8.3.18-0.3.1
  • postgresql-libs >= 8.3.18-0.3.1
Builds
SAT Patch Nr: 6023
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • postgresql >= 8.3.18-0.3.1
  • postgresql-libs >= 8.3.18-0.3.1
  • postgresql-libs-32bit >= 8.3.18-0.3.1
Builds
SAT Patch Nr: 6023
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.18-0.3.1
  • postgresql-contrib >= 8.3.18-0.3.1
  • postgresql-docs >= 8.3.18-0.3.1
  • postgresql-libs >= 8.3.18-0.3.1
  • postgresql-libs-32bit >= 8.3.18-0.3.1
  • postgresql-server >= 8.3.18-0.3.1
Builds
SAT Patch Nr: 6023
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.18-0.3.1
  • postgresql-contrib >= 8.3.18-0.3.1
  • postgresql-docs >= 8.3.18-0.3.1
  • postgresql-libs >= 8.3.18-0.3.1
  • postgresql-server >= 8.3.18-0.3.1
Builds
SAT Patch Nr: 6023
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.18-0.3.1
  • postgresql-contrib >= 8.3.18-0.3.1
  • postgresql-docs >= 8.3.18-0.3.1
  • postgresql-libs >= 8.3.18-0.3.1
  • postgresql-libs-x86 >= 8.3.18-0.3.1
  • postgresql-server >= 8.3.18-0.3.1
Builds
SAT Patch Nr: 6023
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-libs >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-libs >= 8.1.22-0.8.1
  • postgresql-libs-32bit >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • postgresql >= 8.1.22-0.8.1
  • postgresql-contrib >= 8.1.22-0.8.1
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-docs >= 8.1.22-0.8.1
  • postgresql-server >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
SUSE Linux Enterprise Server 10 SP4 for x86
  • postgresql >= 8.1.22-0.8.1
  • postgresql-contrib >= 8.1.22-0.8.1
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-docs >= 8.1.22-0.8.1
  • postgresql-libs >= 8.1.22-0.8.1
  • postgresql-server >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
SUSE Linux Enterprise Server 10 SP4 for IPF
  • postgresql >= 8.1.22-0.8.1
  • postgresql-contrib >= 8.1.22-0.8.1
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-docs >= 8.1.22-0.8.1
  • postgresql-libs >= 8.1.22-0.8.1
  • postgresql-libs-x86 >= 8.1.22-0.8.1
  • postgresql-server >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • postgresql >= 8.1.22-0.8.1
  • postgresql-contrib >= 8.1.22-0.8.1
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-docs >= 8.1.22-0.8.1
  • postgresql-libs >= 8.1.22-0.8.1
  • postgresql-libs-64bit >= 8.1.22-0.8.1
  • postgresql-server >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • postgresql >= 8.1.22-0.8.1
  • postgresql-contrib >= 8.1.22-0.8.1
  • postgresql-devel >= 8.1.22-0.8.1
  • postgresql-docs >= 8.1.22-0.8.1
  • postgresql-libs >= 8.1.22-0.8.1
  • postgresql-libs-32bit >= 8.1.22-0.8.1
  • postgresql-server >= 8.1.22-0.8.1
Builds
ZYPP Patch Nr: 8071
openSUSE 11.4
  • libecpg6 >= 9.0.7-12.2
  • libecpg6-debuginfo >= 9.0.7-12.2
  • libpq5 >= 9.0.7-12.2
  • libpq5-32bit >= 9.0.7-12.2
  • libpq5-debuginfo >= 9.0.7-12.2
  • libpq5-debuginfo-32bit >= 9.0.7-12.2
  • libpq5-debuginfo-x86 >= 9.0.7-12.2
  • libpq5-x86 >= 9.0.7-12.2
  • postgresql >= 9.0.7-12.1
  • postgresql-contrib >= 9.0.7-12.1
  • postgresql-contrib-debuginfo >= 9.0.7-12.1
  • postgresql-debuginfo >= 9.0.7-12.1
  • postgresql-debugsource >= 9.0.7-12.1
  • postgresql-devel >= 9.0.7-12.2
  • postgresql-devel-debuginfo >= 9.0.7-12.2
  • postgresql-docs >= 9.0.7-12.1
  • postgresql-libs >= 9.0.7-12.2
  • postgresql-libs-debugsource >= 9.0.7-12.2
  • postgresql-plperl >= 9.0.7-12.1
  • postgresql-plperl-debuginfo >= 9.0.7-12.1
  • postgresql-plpython >= 9.0.7-12.1
  • postgresql-plpython-debuginfo >= 9.0.7-12.1
  • postgresql-pltcl >= 9.0.7-12.1
  • postgresql-pltcl-debuginfo >= 9.0.7-12.1
  • postgresql-server >= 9.0.7-12.1
  • postgresql-server-debuginfo >= 9.0.7-12.1
Patchnames:
openSUSE-2012-214
openSUSE 13.2
  • libecpg6 >= 9.3.5-2.1.14
  • libpq5 >= 9.3.5-2.1.14
  • libpq5-32bit >= 9.3.5-2.1.14
  • postgresql93 >= 9.3.5-2.1.14
  • postgresql93-contrib >= 9.3.5-2.1.14
  • postgresql93-devel >= 9.3.5-2.1.14
  • postgresql93-docs >= 9.3.5-2.1.14
  • postgresql93-server >= 9.3.5-2.1.14
Patchnames:
openSUSE 13.2 GA libecpg6
openSUSE Leap 42.1
  • libecpg6 >= 9.4.5-1.1
  • libpq5 >= 9.4.5-1.1
  • libpq5-32bit >= 9.4.5-1.1
  • postgresql94 >= 9.4.5-1.2
  • postgresql94-contrib >= 9.4.5-1.2
  • postgresql94-devel >= 9.4.5-1.1
  • postgresql94-docs >= 9.4.5-1.2
  • postgresql94-server >= 9.4.5-1.2
Patchnames:
openSUSE Leap 42.1 GA libecpg6
openSUSE Leap 42.2
  • libecpg6 >= 9.4.9-8.1
  • libpq5 >= 9.4.9-8.1
  • postgresql93-docs >= 9.3.11-4.1
  • postgresql94 >= 9.4.9-8.1
  • postgresql94-contrib >= 9.4.9-8.1
  • postgresql94-devel >= 9.4.9-8.1
  • postgresql94-docs >= 9.4.9-8.1
  • postgresql94-server >= 9.4.9-8.1
Patchnames:
openSUSE Leap 42.2 GA libecpg6
openSUSE Leap 42.2 GA postgresql93-docs