Upstream information

CVE-2012-0866 at MITRE

Description

CREATE TRIGGER in PostgreSQL 8.3.x before 8.3.18, 8.4.x before 8.4.11, 9.0.x before 9.0.7, and 9.1.x before 9.1.3 does not properly check the execute permission for trigger functions marked SECURITY DEFINER, which allows remote authenticated users to execute otherwise restricted triggers on arbitrary data by installing the trigger on an attacker-owned table.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 701489 [RESOLVED / FIXED], 749299 [RESOLVED / FIXED], 749301 [RESOLVED / FIXED], 749303 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libecpg6 >= 9.4.5-4.1
  • libpq5 >= 9.4.5-4.1
  • libpq5-32bit >= 9.4.5-4.1
  • postgresql94 >= 9.4.5-4.5
SUSE Linux Enterprise Desktop 12 SP2
  • libecpg6 >= 9.4.9-14.1
  • libpq5 >= 9.4.9-14.1
  • libpq5-32bit >= 9.4.9-14.1
  • postgresql94 >= 9.4.9-14.1
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.3-2.1
  • libpq5 >= 9.6.3-2.1
  • libpq5-32bit >= 9.6.3-2.1
  • postgresql96 >= 9.6.3-2.4
SUSE Linux Enterprise Desktop 12 SP4
  • libecpg6 >= 10.5-1.3.1
  • libpq5 >= 10.5-1.3.1
  • libpq5-32bit >= 10.5-1.3.1
  • postgresql10 >= 10.5-1.3.2
SUSE Linux Enterprise Desktop 12
  • libecpg6 >= 9.3.5-2.3
  • libpq5 >= 9.3.5-2.3
  • libpq5-32bit >= 9.3.5-2.3
  • postgresql93 >= 9.3.5-2.24
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libecpg6 >= 10.10-1.15.1
  • libpq5 >= 10.10-1.15.1
  • libpq5-32bit >= 10.10-1.15.1
  • postgresql10 >= 10.10-1.15.1
  • postgresql10-contrib >= 10.10-1.15.1
  • postgresql10-docs >= 10.10-1.15.1
  • postgresql10-plperl >= 10.10-1.15.1
  • postgresql10-plpython >= 10.10-1.15.1
  • postgresql10-pltcl >= 10.10-1.15.1
  • postgresql10-server >= 10.10-1.15.1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.18-0.3.1
  • postgresql-contrib >= 8.3.18-0.3.1
  • postgresql-docs >= 8.3.18-0.3.1
  • postgresql-init >= 9.1-0.6.10.1
  • postgresql-libs >= 8.3.18-0.3.1
  • postgresql-libs-32bit >= 8.3.18-0.3.1
  • postgresql-libs-x86 >= 8.3.18-0.3.1
  • postgresql-server >= 8.3.18-0.3.1
Patchnames:
slessp1-postgresql
SUSE Linux Enterprise Server 11 SP3
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
SUSE Linux Enterprise Server 11 SP4
  • libecpg6 >= 9.4.4-0.6.2
  • libpq5 >= 9.4.4-0.6.2
  • libpq5-32bit >= 9.4.4-0.6.2
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
  • postgresql94 >= 9.4.4-0.6.2
  • postgresql94-contrib >= 9.4.4-0.6.2
  • postgresql94-docs >= 9.4.4-0.6.2
  • postgresql94-server >= 9.4.4-0.6.2
SUSE Linux Enterprise Server 12 SP1
  • libecpg6 >= 9.4.5-4.1
  • libpq5 >= 9.4.5-4.1
  • libpq5-32bit >= 9.4.5-4.1
  • postgresql94 >= 9.4.5-4.5
  • postgresql94-contrib >= 9.4.5-4.5
  • postgresql94-docs >= 9.4.5-4.5
  • postgresql94-server >= 9.4.5-4.5
SUSE Linux Enterprise Server 12 SP2
  • libecpg6 >= 9.4.9-14.1
  • libpq5 >= 9.4.9-14.1
  • libpq5-32bit >= 9.4.9-14.1
  • postgresql94 >= 9.4.9-14.1
  • postgresql94-contrib >= 9.4.9-14.1
  • postgresql94-docs >= 9.4.9-14.1
  • postgresql94-server >= 9.4.9-14.1
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 9.6.3-2.1
  • libpq5 >= 9.6.3-2.1
  • libpq5-32bit >= 9.6.3-2.1
  • postgresql96 >= 9.6.3-2.4
  • postgresql96-contrib >= 9.6.3-2.4
  • postgresql96-docs >= 9.6.3-2.4
  • postgresql96-server >= 9.6.3-2.4
SUSE Linux Enterprise Server 12 SP4
  • libecpg6 >= 10.5-1.3.1
  • libpq5 >= 10.5-1.3.1
  • libpq5-32bit >= 10.5-1.3.1
  • postgresql10 >= 10.5-1.3.2
  • postgresql10-contrib >= 10.5-1.3.2
  • postgresql10-docs >= 10.5-1.3.2
  • postgresql10-server >= 10.5-1.3.2
SUSE Linux Enterprise Server 12
  • libecpg6 >= 9.3.5-2.3
  • libpq5 >= 9.3.5-2.3
  • libpq5-32bit >= 9.3.5-2.3
  • postgresql93 >= 9.3.5-2.24
  • postgresql93-contrib >= 9.3.5-2.24
  • postgresql93-docs >= 9.3.5-2.24
  • postgresql93-server >= 9.3.5-2.24
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libecpg6 >= 9.4.9-14.1
  • libpq5 >= 9.4.9-14.1
  • postgresql94 >= 9.4.9-14.1
  • postgresql94-contrib >= 9.4.9-14.1
  • postgresql94-docs >= 9.4.9-14.1
  • postgresql94-server >= 9.4.9-14.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql-devel >= 8.3.23-0.4.1
  • postgresql94-devel >= 9.4.4-0.6.2
SUSE Linux Enterprise Software Development Kit 12 SP1
  • postgresql94-devel >= 9.4.5-4.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • postgresql94-devel >= 9.4.9-14.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.3-2.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • postgresql10-devel >= 10.5-1.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • postgresql10-devel >= 10.10-1.15.1
SUSE Linux Enterprise Software Development Kit 12
  • postgresql93-devel >= 9.3.5-2.3
openSUSE Leap 15.0
  • postgresql96 >= 9.6.8-lp150.1.2
  • postgresql96-server >= 9.6.8-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA postgresql96-9.6.8-lp150.1.2
openSUSE Tumbleweed
  • libecpg6 >= 9.5.4-1.2
  • libecpg6-32bit >= 9.5.4-1.2
  • libpq5 >= 9.5.4-1.2
  • libpq5-32bit >= 9.5.4-1.2
  • postgresql93 >= 9.3.15-1.1
  • postgresql93-contrib >= 9.3.15-1.1
  • postgresql93-devel >= 9.3.15-1.1
  • postgresql93-docs >= 9.3.15-1.1
  • postgresql93-plperl >= 9.3.15-1.1
  • postgresql93-plpython >= 9.3.15-1.1
  • postgresql93-pltcl >= 9.3.15-1.1
  • postgresql93-server >= 9.3.15-1.1
  • postgresql93-test >= 9.3.15-1.1
  • postgresql94 >= 9.4.10-1.1
  • postgresql94-contrib >= 9.4.10-1.1
  • postgresql94-devel >= 9.4.10-1.1
  • postgresql94-docs >= 9.4.10-1.1
  • postgresql94-plperl >= 9.4.10-1.1
  • postgresql94-plpython >= 9.4.10-1.1
  • postgresql94-pltcl >= 9.4.10-1.1
  • postgresql94-server >= 9.4.10-1.1
  • postgresql94-test >= 9.4.10-1.1
  • postgresql95 >= 9.5.4-1.2
  • postgresql95-contrib >= 9.5.4-1.2
  • postgresql95-devel >= 9.5.4-1.2
  • postgresql95-docs >= 9.5.4-1.2
  • postgresql95-plperl >= 9.5.4-1.2
  • postgresql95-plpython >= 9.5.4-1.2
  • postgresql95-pltcl >= 9.5.4-1.2
  • postgresql95-server >= 9.5.4-1.2
  • postgresql95-test >= 9.5.4-1.2
Patchnames:
openSUSE Tumbleweed GA libecpg6-32bit-9.5.4-1.2
openSUSE Tumbleweed GA postgresql93-9.3.15-1.1
openSUSE Tumbleweed GA postgresql94-9.4.10-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 postgresql Released
SLED-10-SP4 postgresql Released
SLES-10-SP3 postgresql Released
SLES-10-SP4 postgresql Released
SLES_LTSS-10-SP4 postgresql Released
SUSE Linux Enterprise Desktop 11 SP1 postgresql Released
SUSE Linux Enterprise Point of Service 11 SP3 postgresql94 In progress
SUSE Linux Enterprise Server 11 SP1 postgresql Released
SUSE Linux Enterprise Server 11 SP1 LTSS postgresql Released
SUSE Linux Enterprise Server 11 SP4 LTSS postgresql94 In progress
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 postgresql Released