Upstream information

CVE-2022-3676 at MITRE

Description

In Eclipse Openj9 before version 0.35.0, interface calls can be inlined without a runtime type check. Malicious bytecode could make use of this inlining to access or modify memory via an incompatible type.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1204703 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
SUSE Linux Enterprise Server 12 SP2-BCL
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2022-4591
SUSE-SLE-SERVER-12-SP2-BCL-2022-4602
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2022-4591
SUSE-SLE-SERVER-12-SP4-ESPOS-2022-4602
SUSE Linux Enterprise Server 12 SP4-LTSS
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2022-4591
SUSE-SLE-SERVER-12-SP4-LTSS-2022-4602
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4591
SUSE-SLE-SDK-12-SP5-2022-4602
SUSE-SLE-SERVER-12-SP5-2022-4591
SUSE-SLE-SERVER-12-SP5-2022-4602
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2022-4591
SUSE-SLE-SAP-12-SP4-2022-4602
SUSE Linux Enterprise Software Development Kit 12 SP5
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4591
SUSE-SLE-SDK-12-SP5-2022-4602
SUSE OpenStack Cloud 9
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-OpenStack-Cloud-9-2022-4591
SUSE-OpenStack-Cloud-9-2022-4602
SUSE OpenStack Cloud Crowbar 9
  • java-1_7_1-ibm >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-alsa >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-devel >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-jdbc >= 1.7.1_sr5.15-38.77.1
  • java-1_7_1-ibm-plugin >= 1.7.1_sr5.15-38.77.1
  • java-1_8_0-ibm >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-alsa >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-devel >= 1.8.0_sr7.20-30.102.1
  • java-1_8_0-ibm-plugin >= 1.8.0_sr7.20-30.102.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2022-4591
SUSE-OpenStack-Cloud-Crowbar-9-2022-4602
openSUSE Leap 15.3
  • java-1_8_0-openj9 >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-accessibility >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-demo >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-devel >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-headless >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-javadoc >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-src >= 1.8.0.352-150200.3.27.1
Patchnames:
openSUSE-SLE-15.3-2022-4250
openSUSE Leap 15.4
  • java-1_8_0-openj9 >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-accessibility >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-demo >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-devel >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-headless >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-javadoc >= 1.8.0.352-150200.3.27.1
  • java-1_8_0-openj9-src >= 1.8.0.352-150200.3.27.1
Patchnames:
openSUSE-SLE-15.4-2022-4250
openSUSE Tumbleweed
  • java-11-openj9 >= 11.0.17.0-1.1
  • java-11-openj9-accessibility >= 11.0.17.0-1.1
  • java-11-openj9-demo >= 11.0.17.0-1.1
  • java-11-openj9-devel >= 11.0.17.0-1.1
  • java-11-openj9-headless >= 11.0.17.0-1.1
  • java-11-openj9-javadoc >= 11.0.17.0-1.1
  • java-11-openj9-jmods >= 11.0.17.0-1.1
  • java-11-openj9-src >= 11.0.17.0-1.1
  • java-17-openj9 >= 17.0.5.0-1.1
  • java-17-openj9-accessibility >= 17.0.5.0-1.1
  • java-17-openj9-demo >= 17.0.5.0-1.1
  • java-17-openj9-devel >= 17.0.5.0-1.1
  • java-17-openj9-headless >= 17.0.5.0-1.1
  • java-17-openj9-javadoc >= 17.0.5.0-1.1
  • java-17-openj9-jmods >= 17.0.5.0-1.1
  • java-17-openj9-src >= 17.0.5.0-1.1
  • java-1_8_0-openj9 >= 1.8.0.352-1.1
  • java-1_8_0-openj9-accessibility >= 1.8.0.352-1.1
  • java-1_8_0-openj9-demo >= 1.8.0.352-1.1
  • java-1_8_0-openj9-devel >= 1.8.0.352-1.1
  • java-1_8_0-openj9-headless >= 1.8.0.352-1.1
  • java-1_8_0-openj9-javadoc >= 1.8.0.352-1.1
  • java-1_8_0-openj9-src >= 1.8.0.352-1.1
Patchnames:
openSUSE Tumbleweed GA java-11-openj9-11.0.17.0-1.1
openSUSE Tumbleweed GA java-17-openj9-17.0.5.0-1.1
openSUSE Tumbleweed GA java-1_8_0-openj9-1.8.0.352-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12 SP5 java-1_7_1-ibm Released
SUSE Linux Enterprise Server 12 SP5 java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12-LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 java-1_7_1-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 java-1_8_0-ibm Released
SUSE Linux Enterprise Software Development Kit 12 SP5 java-1_7_1-ibm Released
SUSE Linux Enterprise Software Development Kit 12 SP5 java-1_8_0-ibm Released
openSUSE Leap 15.4 java-1_8_0-openj9 Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL java-1_7_1-ibm Released
SUSE Linux Enterprise Server 12 SP2-BCL java-1_8_0-ibm Released
SUSE Linux Enterprise Server 12 SP4 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP4 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP4-LTSS java-1_7_1-ibm Released
SUSE Linux Enterprise Server 12 SP4-LTSS java-1_8_0-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 java-1_7_1-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 java-1_8_0-ibm Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 java-1_7_1-ibm Affected
HPE Helion OpenStack 8 java-1_8_0-ibm Affected
SUSE Linux Enterprise Desktop 12 java-1_7_1-ibm Affected
SUSE Linux Enterprise Desktop 12 SP1 java-1_7_1-ibm Affected
SUSE Linux Enterprise Desktop 12 SP1 java-1_8_0-ibm Affected
SUSE Linux Enterprise Desktop 12 SP2 java-1_7_1-ibm Affected
SUSE Linux Enterprise Desktop 12 SP2 java-1_8_0-ibm Affected
SUSE Linux Enterprise Desktop 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise Desktop 12 SP3 java-1_8_0-ibm Affected
SUSE Linux Enterprise Desktop 12 SP4 java-1_7_1-ibm Affected
SUSE Linux Enterprise Desktop 12 SP4 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 11 SP3 java-1_7_0-ibm Affected
SUSE Linux Enterprise Server 11 SP3-LTSS java-1_7_0-ibm Affected
SUSE Linux Enterprise Server 12 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP1 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP1 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP1-LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP1-LTSS java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP2 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP2 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP2-LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP2-LTSS java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP3 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP3-BCL java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP3-BCL java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP3-LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP3-LTSS java-1_8_0-ibm Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS java-1_7_1-ibm Released
SUSE Linux Enterprise Server 12 SP4-ESPOS java-1_8_0-ibm Released
SUSE Linux Enterprise Server for SAP Applications 12 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 java-1_8_0-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 java-1_8_0-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 java-1_7_1-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 java-1_7_1-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 java-1_8_0-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 java-1_7_1-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 java-1_8_0-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 java-1_8_0-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 java-1_7_1-ibm Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 java-1_8_0-ibm Affected
SUSE OpenStack Cloud 7 java-1_7_1-ibm Affected
SUSE OpenStack Cloud 7 java-1_8_0-ibm Affected
SUSE OpenStack Cloud 8 java-1_7_1-ibm Affected
SUSE OpenStack Cloud 8 java-1_8_0-ibm Affected
SUSE OpenStack Cloud 9 java-1_7_1-ibm Released
SUSE OpenStack Cloud 9 java-1_8_0-ibm Released
SUSE OpenStack Cloud Crowbar 8 java-1_7_1-ibm Affected
SUSE OpenStack Cloud Crowbar 8 java-1_8_0-ibm Affected
SUSE OpenStack Cloud Crowbar 9 java-1_7_1-ibm Released
SUSE OpenStack Cloud Crowbar 9 java-1_8_0-ibm Released


SUSE Timeline for this CVE

CVE page created: Tue Oct 25 02:36:54 2022
CVE page last modified: Wed Jan 25 01:37:14 2023