Upstream information

CVE-2019-10137 at MITRE

Description

A path traversal flaw was found in spacewalk-proxy, all versions through 2.9, in the way the proxy processes cached client tokens. A remote, unauthenticated attacker could use this flaw to test the existence of arbitrary files, if they have access to the proxy's filesystem, or can execute arbitrary code in the context of the httpd process.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High None
SUSE Bugzilla entry: 1136476 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for SUSE Manager Proxy 4.0
  • python3-spacewalk-backend-libs >= 4.0.22-3.3.1
  • spacewalk-backend >= 4.0.22-3.3.1
  • spacewalk-base-minimal >= 4.0.14-3.3.1
  • spacewalk-base-minimal-config >= 4.0.14-3.3.1
  • spacewalk-proxy >= 4.0.12-3.3.1
  • spacewalk-proxy-broker >= 4.0.12-3.3.1
  • spacewalk-proxy-common >= 4.0.12-3.3.1
  • spacewalk-proxy-management >= 4.0.12-3.3.1
  • spacewalk-proxy-package-manager >= 4.0.12-3.3.1
  • spacewalk-proxy-redirect >= 4.0.12-3.3.1
  • spacewalk-proxy-salt >= 4.0.12-3.3.1
  • spacewalk-web >= 4.0.14-3.3.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Proxy-4.0-2019-1789
SUSE Linux Enterprise Module for SUSE Manager Server 4.0
  • python3-spacewalk-backend-libs >= 4.0.22-3.3.1
  • spacewalk-backend >= 4.0.22-3.3.1
  • spacewalk-backend-app >= 4.0.22-3.3.1
  • spacewalk-backend-applet >= 4.0.22-3.3.1
  • spacewalk-backend-config-files >= 4.0.22-3.3.1
  • spacewalk-backend-config-files-common >= 4.0.22-3.3.1
  • spacewalk-backend-config-files-tool >= 4.0.22-3.3.1
  • spacewalk-backend-iss >= 4.0.22-3.3.1
  • spacewalk-backend-iss-export >= 4.0.22-3.3.1
  • spacewalk-backend-package-push-server >= 4.0.22-3.3.1
  • spacewalk-backend-server >= 4.0.22-3.3.1
  • spacewalk-backend-sql >= 4.0.22-3.3.1
  • spacewalk-backend-sql-postgresql >= 4.0.22-3.3.1
  • spacewalk-backend-tools >= 4.0.22-3.3.1
  • spacewalk-backend-xml-export-libs >= 4.0.22-3.3.1
  • spacewalk-backend-xmlrpc >= 4.0.22-3.3.1
  • spacewalk-base >= 4.0.14-3.3.1
  • spacewalk-base-minimal >= 4.0.14-3.3.1
  • spacewalk-base-minimal-config >= 4.0.14-3.3.1
  • spacewalk-html >= 4.0.14-3.3.1
  • spacewalk-web >= 4.0.14-3.3.1
  • susemanager-doc-indexes >= 4.0-10.3.1
  • susemanager-docs_en >= 4.0-10.3.1
  • susemanager-docs_en-pdf >= 4.0-10.3.1
  • susemanager-sync-data >= 4.0.12-3.3.1
  • susemanager-web-libs >= 4.0.14-3.3.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.0-2019-1789
SUSE Manager Proxy 3.2
  • release-notes-susemanager-proxy >= 3.2.9-0.16.27.1
  • spacewalk-backend >= 2.8.57.17-3.33.1
  • spacewalk-backend-libs >= 2.8.57.17-3.33.1
  • spacewalk-base-minimal >= 2.8.7.17-3.30.1
  • spacewalk-base-minimal-config >= 2.8.7.17-3.30.1
  • spacewalk-proxy >= 2.8.5.6-3.11.1
  • spacewalk-proxy-broker >= 2.8.5.6-3.11.1
  • spacewalk-proxy-common >= 2.8.5.6-3.11.1
  • spacewalk-proxy-management >= 2.8.5.6-3.11.1
  • spacewalk-proxy-package-manager >= 2.8.5.6-3.11.1
  • spacewalk-proxy-redirect >= 2.8.5.6-3.11.1
  • spacewalk-proxy-salt >= 2.8.5.6-3.11.1
  • spacewalk-web >= 2.8.7.17-3.30.1
  • susemanager-web-libs >= 2.8.7.17-3.30.1
Patchnames:
SUSE-SUSE-Manager-Proxy-3.2-2019-1790
SUSE Manager Server 3.2
  • release-notes-susemanager >= 3.2.9-6.35.1
  • spacewalk-backend >= 2.8.57.17-3.33.1
  • spacewalk-backend-app >= 2.8.57.17-3.33.1
  • spacewalk-backend-applet >= 2.8.57.17-3.33.1
  • spacewalk-backend-config-files >= 2.8.57.17-3.33.1
  • spacewalk-backend-config-files-common >= 2.8.57.17-3.33.1
  • spacewalk-backend-config-files-tool >= 2.8.57.17-3.33.1
  • spacewalk-backend-iss >= 2.8.57.17-3.33.1
  • spacewalk-backend-iss-export >= 2.8.57.17-3.33.1
  • spacewalk-backend-libs >= 2.8.57.17-3.33.1
  • spacewalk-backend-package-push-server >= 2.8.57.17-3.33.1
  • spacewalk-backend-server >= 2.8.57.17-3.33.1
  • spacewalk-backend-sql >= 2.8.57.17-3.33.1
  • spacewalk-backend-sql-oracle >= 2.8.57.17-3.33.1
  • spacewalk-backend-sql-postgresql >= 2.8.57.17-3.33.1
  • spacewalk-backend-tools >= 2.8.57.17-3.33.1
  • spacewalk-backend-xml-export-libs >= 2.8.57.17-3.33.1
  • spacewalk-backend-xmlrpc >= 2.8.57.17-3.33.1
  • spacewalk-base >= 2.8.7.17-3.30.1
  • spacewalk-base-minimal >= 2.8.7.17-3.30.1
  • spacewalk-base-minimal-config >= 2.8.7.17-3.30.1
  • spacewalk-html >= 2.8.7.17-3.30.1
  • spacewalk-web >= 2.8.7.17-3.30.1
  • susemanager-web-libs >= 2.8.7.17-3.30.1
Patchnames:
SUSE-SUSE-Manager-Server-3.2-2019-1790


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for SUSE Manager Proxy 4.0 GA spacewalk-proxy Released
SUSE Manager Proxy 3.1 spacewalk-proxy Affected
SUSE Manager Proxy 3.2 spacewalk-proxy Released