Upstream information

CVE-2016-10504 at MITRE

Description

Heap-based buffer overflow vulnerability in the opj_mqc_byteout function in mqc.c in OpenJPEG before 2.2.0 allows remote attackers to cause a denial of service (application crash) via a crafted bmp file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 7.5
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 9.4
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact None High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1056351 [RESOLVED / UPSTREAM], 1179594 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • libopenjp2-7 >= 2.3.0-1.25
  • openjpeg2 >= 2.3.0-1.25
  • openjpeg2-devel >= 2.3.0-1.25
openSUSE Leap 15.0
  • libopenjp2-7 >= 2.3.0-lp150.1.5
Patchnames:
openSUSE Leap 15.0 GA libopenjp2-7-2.3.0-lp150.1.5
openSUSE Tumbleweed
  • libopenjp2-7 >= 2.4.0-1.4
  • libopenjp2-7-32bit >= 2.4.0-1.4
  • openjpeg2 >= 2.4.0-1.4
  • openjpeg2-devel >= 2.4.0-1.4
  • openjpeg2-devel-doc >= 2.4.0-1.4
Patchnames:
openSUSE Tumbleweed GA libopenjp2-7-2.4.0-1.4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 openjpeg2 Already fixed
SUSE Enterprise Storage 6 openjpeg2 Already fixed
SUSE Linux Enterprise Desktop 12 SP2 openjpeg2 Affected
SUSE Linux Enterprise Desktop 12 SP3 openjpeg2 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS openjpeg2 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS openjpeg2 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 openjpeg2 Already fixed
SUSE Linux Enterprise Server 12 SP2 openjpeg2 Not affected
SUSE Linux Enterprise Server 12 SP3 openjpeg2 Not affected
SUSE Linux Enterprise Server 15 LTSS openjpeg2 Already fixed
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux openjpeg2 Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS openjpeg2 Already fixed
SUSE Linux Enterprise Server ESPOS 15 openjpeg2 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 openjpeg2 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openjpeg2 Already fixed
SUSE Manager Proxy 4.0 openjpeg2 Already fixed
SUSE Manager Retail Branch Server 4.0 openjpeg2 Already fixed
SUSE Manager Server 4.0 openjpeg2 Already fixed