Security update for pacemaker

SUSE Security Update: Security update for pacemaker
Announcement ID: SUSE-SU-2020:3073-1
Rating: important
References: #1167171 #1173668 #1175557 #1177916
Cross-References:CVE-2020-25654
Affected Products:
  • SUSE Linux Enterprise High Availability 15-SP1

An update that solves one vulnerability and has three fixes is now available.

Description:

This update for pacemaker fixes the following issues:

  • executor: restrict certain IPC requests to Pacemaker daemons (CVE-2020-25654, bsc#1177916)
  • extra: add vim modelines to agents
  • extra: quote shell variables in agent code where appropriate (bsc#1175557)
  • extra: remove trailing whitespace from agent code
  • extra: update agent boilerplate (copyright/license notices)
  • extra: use 4-space indents in resource agent code
  • extra: use ":=" where appropriate in agent code
  • fencer: restrict certain IPC requests to privileged users (CVE-2020-25654, bsc#1177916)
  • move bcond_with/without up front for e.g. pcmk_release
  • pacemakerd: ignore shutdown requests from unprivileged users (CVE-2020-25654, bsc#1177916)
  • rpm: add spec option for enabling CIB secrets
  • rpm: put user-configurable items at top of spec
  • rpm: use the user/group ID 90 for haclient/hacluster to be consistent with cluster-glue (bsc#1167171)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 15-SP1:
    zypper in -t patch SUSE-SLE-Product-HA-15-SP1-2020-3073=1

Package List:

  • SUSE Linux Enterprise High Availability 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libpacemaker-devel-2.0.1+20190417.13d370ca9-3.15.1
    • libpacemaker3-2.0.1+20190417.13d370ca9-3.15.1
    • libpacemaker3-debuginfo-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-cli-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-cli-debuginfo-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-debuginfo-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-debugsource-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-remote-2.0.1+20190417.13d370ca9-3.15.1
    • pacemaker-remote-debuginfo-2.0.1+20190417.13d370ca9-3.15.1
  • SUSE Linux Enterprise High Availability 15-SP1 (noarch):
    • pacemaker-cts-2.0.1+20190417.13d370ca9-3.15.1

References: