Security update for autoyast2

SUSE Security Update: Security update for autoyast2
Announcement ID: SUSE-SU-2020:1296-1
Rating: moderate
References: #1109310 #1133045 #1140711 #1164105 #1168123 #1168281 #1170082
Cross-References:CVE-2019-18905
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that solves one vulnerability and has 6 fixes is now available.

Description:

This update for autoyast2 to version 4.1.15 fixes the following issues:
Security issue fixed:

  • CVE-2019-18905: Removed all "--gpg-auto-import-keys" options from zypper commands (bsc#1140711).

Non-security issue fixed:
  • Fix desktop files updating some icons and groups (bsc#1168123).
  • Restored some missing icons (bsc#1168123, bsc#1109310 and bsc#1168281).
  • Service for init scripts: Try to start "network-online.target" before starting the autoyast init scripts in order to get a working network (bsc#1164105).
  • Always re-probe storage after pre-scripts (bsc#1170082, bsc#1133045).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-1296=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (noarch):
    • autoyast2-4.1.15-3.13.1
    • autoyast2-installation-4.1.15-3.13.1

References: