Upstream information

CVE-2019-18905 at MITRE

Description

A Insufficient Verification of Data Authenticity vulnerability in autoyast2 of SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Server 15 allows remote attackers to MITM connections when deprecated and unused functionality of autoyast is used to create images. This issue affects: SUSE Linux Enterprise Server 12 autoyast2 version 4.1.9-3.9.1 and prior versions. SUSE Linux Enterprise Server 15 autoyast2 version 4.0.70-3.20.1 and prior versions.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.9 5.3
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1140711 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP1-Azure-BYOS
Image SLES15-SP1-Azure-HPC-BYOS
Image SLES15-SP1-EC2-HPC-HVM-BYOS
Image SLES15-SP1-EC2-HVM-BYOS
Image SLES15-SP1-GCE-BYOS
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-Azure-BYOS-Server
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-EC2-HVM-BYOS-Server
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Proxy
Image SLES15-SP1-Manager-4-0-GCE-BYOS-Server
Image SLES15-SP1-OCI-BYOS
Image SLES15-SP1-SAP-Azure
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-EC2-HVM
Image SLES15-SP1-SAP-EC2-HVM-BYOS
Image SLES15-SP1-SAP-GCE
Image SLES15-SP1-SAP-GCE-BYOS
Image SLES15-SP1-SAP-OCI-BYOS
Image SLES15-SP1-SAPCAL-Azure
Image SLES15-SP1-SAPCAL-EC2-HVM
Image SLES15-SP1-SAPCAL-GCE
  • autoyast2-installation >= 4.1.15-3.13.1
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
  • autoyast2 >= 4.1.15-3.13.1
  • autoyast2-installation >= 4.1.15-3.13.1
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • autoyast2 >= 4.1.15-3.13.1
  • autoyast2-installation >= 4.1.15-3.13.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2020-1296
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • autoyast2 >= 4.2.37-1.6
  • autoyast2-installation >= 4.2.37-1.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA autoyast2-4.2.37-1.6
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • autoyast2 >= 4.3.77-1.1
  • autoyast2-installation >= 4.3.77-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA autoyast2-4.3.77-1.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • autoyast2 >= 4.4.36-150400.1.6
  • autoyast2-installation >= 4.4.36-150400.1.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA autoyast2-4.4.36-150400.1.6
openSUSE Leap 15.1
  • autoyast2 >= 4.1.15-lp151.2.12.1
  • autoyast2-installation >= 4.1.15-lp151.2.12.1
Patchnames:
openSUSE-2020-676
openSUSE Leap 15.2
  • autoyast2 >= 4.2.37-lp152.1.1
  • autoyast2-installation >= 4.2.37-lp152.1.1
Patchnames:
openSUSE Leap 15.2 GA autoyast2-4.2.37-lp152.1.1
openSUSE Leap 15.3
  • autoyast2 >= 4.3.77-1.1
  • autoyast2-installation >= 4.3.77-1.1
Patchnames:
openSUSE Leap 15.3 GA autoyast2-4.3.77-1.1
openSUSE Leap 15.4
  • autoyast2 >= 4.4.36-150400.1.6
  • autoyast2-installation >= 4.4.36-150400.1.6
Patchnames:
openSUSE Leap 15.4 GA autoyast2-4.4.36-150400.1.6
openSUSE Tumbleweed
  • autoyast2 >= 4.4.16-1.1
  • autoyast2-installation >= 4.4.16-1.1
Patchnames:
openSUSE Tumbleweed GA autoyast2-4.4.16-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications autoyast2 Not affected
SUSE CaaS Platform 4.0 autoyast2 Released
SUSE CaaS Platform 4.5 autoyast2 Already fixed
SUSE Enterprise Storage 6 autoyast2 Released
SUSE Enterprise Storage 7 autoyast2 Already fixed
SUSE Linux Enterprise Desktop 12 SP3 autoyast2 Ignore
SUSE Linux Enterprise Desktop 12 SP4 autoyast2 Ignore
SUSE Linux Enterprise Desktop 15 autoyast2 Affected
SUSE Linux Enterprise Desktop 15 SP1 autoyast2 Released
SUSE Linux Enterprise Desktop 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise Desktop 15 SP3 autoyast2 Already fixed
SUSE Linux Enterprise Desktop 15 SP4 autoyast2 Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP4 autoyast2 Ignore
SUSE Linux Enterprise High Performance Computing 15 autoyast2 Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS autoyast2 In progress
SUSE Linux Enterprise High Performance Computing 15 SP1 autoyast2 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS autoyast2 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS autoyast2 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS autoyast2 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS autoyast2 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 autoyast2 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 autoyast2 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 autoyast2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 autoyast2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 autoyast2 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 autoyast2 Already fixed
SUSE Linux Enterprise Real Time 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise Server 11 SP1 autoyast2 Not affected
SUSE Linux Enterprise Server 11 SP3 autoyast2 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS autoyast2 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS autoyast2 Not affected
SUSE Linux Enterprise Server 12 LTSS autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP1 autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP2 BCL autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP2 LTSS autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP3 autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP3 BCL autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP4 autoyast2 Ignore
SUSE Linux Enterprise Server 12 SP4 LTSS autoyast2 Ignore
SUSE Linux Enterprise Server 15 autoyast2 Affected
SUSE Linux Enterprise Server 15 ESPOS autoyast2 In progress
SUSE Linux Enterprise Server 15 LTSS autoyast2 In progress
SUSE Linux Enterprise Server 15 SP1 autoyast2 Released
SUSE Linux Enterprise Server 15 SP1 LTSS autoyast2 Released
SUSE Linux Enterprise Server 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise Server 15 SP2 LTSS autoyast2 Already fixed
SUSE Linux Enterprise Server 15 SP3 autoyast2 Already fixed
SUSE Linux Enterprise Server 15 SP4 autoyast2 Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 autoyast2 Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 autoyast2 Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP2 autoyast2 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 autoyast2 Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP4 autoyast2 Ignore
SUSE Linux Enterprise Server for SAP Applications 15 autoyast2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 autoyast2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 autoyast2 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 autoyast2 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 autoyast2 Already fixed
SUSE Linux Enterprise Storage 6 autoyast2 Released
SUSE Linux Enterprise Storage 7 autoyast2 Already fixed
SUSE Linux Enterprise Storage 7.1 autoyast2 Already fixed
SUSE Manager Proxy 4.0 autoyast2 Released
SUSE Manager Proxy 4.1 autoyast2 Already fixed
SUSE Manager Proxy 4.2 autoyast2 Already fixed
SUSE Manager Proxy 4.3 autoyast2 Already fixed
SUSE Manager Retail Branch Server 4.0 autoyast2 Released
SUSE Manager Retail Branch Server 4.1 autoyast2 Already fixed
SUSE Manager Retail Branch Server 4.2 autoyast2 Already fixed
SUSE Manager Retail Branch Server 4.3 autoyast2 Already fixed
SUSE Manager Server 4.0 autoyast2 Released
SUSE Manager Server 4.1 autoyast2 Already fixed
SUSE Manager Server 4.2 autoyast2 Already fixed
SUSE Manager Server 4.3 autoyast2 Already fixed