Recommended update for python-google-api-python-client

SUSE Recommended Update: Recommended update for python-google-api-python-client
Announcement ID: SUSE-RU-2020:1094-1
Rating: moderate
References: #1088358 #1160933
Affected Products:
  • SUSE Linux Enterprise Module for Public Cloud 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Enterprise Storage 6

An update that has two recommended fixes can now be installed.

Description:

This update for python-google-api-python-client fixes the following issues:

  • Fix dependencies to use google-auth instead of deprecated oauth2client (bsc#1160933, jsc#ECO-1148)

python-cachetools 2.0.1 is shipped to the Public Cloud Module. python-google-auth 1.5.1 is shipped to the Public Cloud Module.

python-google-api-python-client was updated to:
  • Upgrade to 1.7.4: just series of minor bugfixes

  • Fix check for error text on Python 3.7. (#278)
  • Use new Auth URIs. (#281)
  • Add code-of-conduct document. (#270)
  • Fix some typos in test_urllib3.py (#268)
  • Warn when using user credentials from the Cloud SDK (#266)
  • Add compute engine-based IDTokenCredentials (#236)
  • Corrected some typos (#265)

Update to 1.4.2:
  • Raise a helpful exception when trying to refresh credentials without a refresh token. (#262)
  • Fix links to README and CONTRIBUTING in docs/index.rst. (#260)
  • Fix a typo in credentials.py. (#256)
  • Use pytest instead of py.test per upstream recommendation, #dropthedot. (#255)
  • Fix typo on exemple of jwt usage (#245)

New upstream release 1.4.1 (bsc#1088358)
  • Added a check for the cryptography version before attempting to use it.

  • From version 1.4.0 - Added `cryptography`-based RSA signer and verifier. - Added `google.oauth2.service_account.IDTokenCredentials`. - Improved documentation around ID Tokens
  • From version 1.3.0 - Added ``google.oauth2.credentials.Credentials.from_authorized_user_file``. - Dropped direct pyasn1 dependency in favor of letting ``pyasn1-modules`` specify the right version. - ``default()`` now checks for the project ID environment var before warning about missing project ID. - Fixed the docstrings for ``has_scopes()`` and ``with_scopes()``. - Fixed example in docstring for ``ReadOnlyScoped``. - Made ``transport.requests`` use timeouts and retries to improve reliability.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Public Cloud 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-SP1-2020-1094=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1094=1
  • SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2020-1094=1

Package List:

  • SUSE Linux Enterprise Module for Public Cloud 15-SP1 (noarch):
    • python3-cachetools-2.0.1-3.3.1
    • python3-google-api-python-client-1.7.4-3.3.1
    • python3-google-auth-1.5.1-3.2.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (noarch):
    • python2-cachetools-2.0.1-3.3.1
    • python2-google-api-python-client-1.7.4-3.3.1
    • python2-google-auth-1.5.1-3.2.1
    • python3-cachetools-2.0.1-3.3.1
    • python3-google-auth-1.5.1-3.2.1
  • SUSE Enterprise Storage 6 (noarch):
    • python3-cachetools-2.0.1-3.3.1
    • python3-google-auth-1.5.1-3.2.1

References: