Recommended update for libsolv

SUSE Recommended Update: Recommended update for libsolv
Announcement ID: SUSE-RU-2020:1026-1
Rating: moderate
References: #1159314
Affected Products:
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that has one recommended fix can now be installed.

Description:

This update for libsolv fixes the following issues:
libsolv was updated to version 0.7.11:

  • fix solv_zchunk decoding error if large chunks are used (bsc#1159314)
  • treat retracted pathes as irrelevant
  • made add_update_target work with multiversion installs

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1026=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1026=1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-1026=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-1026=1

Package List:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libsolv-debuginfo-0.7.11-3.16.1
    • libsolv-debugsource-0.7.11-3.16.1
    • python-solv-0.7.11-3.16.1
    • python-solv-debuginfo-0.7.11-3.16.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libsolv-debuginfo-0.7.11-3.16.1
    • libsolv-debugsource-0.7.11-3.16.1
    • libsolv-demo-0.7.11-3.16.1
    • libsolv-demo-debuginfo-0.7.11-3.16.1
    • libzypp-debuginfo-17.19.0-3.16.1
    • libzypp-debugsource-17.19.0-3.16.1
    • libzypp-devel-doc-17.19.0-3.16.1
    • python-solv-0.7.11-3.16.1
    • python-solv-debuginfo-0.7.11-3.16.1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libsolv-debuginfo-0.7.11-3.16.1
    • libsolv-debugsource-0.7.11-3.16.1
    • perl-solv-0.7.11-3.16.1
    • perl-solv-debuginfo-0.7.11-3.16.1
    • ruby-solv-0.7.11-3.16.1
    • ruby-solv-debuginfo-0.7.11-3.16.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libsolv-debuginfo-0.7.11-3.16.1
    • libsolv-debugsource-0.7.11-3.16.1
    • libsolv-devel-0.7.11-3.16.1
    • libsolv-devel-debuginfo-0.7.11-3.16.1
    • libsolv-tools-0.7.11-3.16.1
    • libsolv-tools-debuginfo-0.7.11-3.16.1
    • libzypp-17.19.0-3.16.1
    • libzypp-debuginfo-17.19.0-3.16.1
    • libzypp-debugsource-17.19.0-3.16.1
    • libzypp-devel-17.19.0-3.16.1
    • python3-solv-0.7.11-3.16.1
    • python3-solv-debuginfo-0.7.11-3.16.1

References: