Security update for python-numpy

SUSE Security Update: Security update for python-numpy
Announcement ID: SUSE-SU-2019:2462-2
Rating: moderate
References: #1149203
Cross-References: CVE-2019-6446
Affected Products:
  • SUSE Linux Enterprise Module for Python2 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for HPC 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that fixes one vulnerability is now available.

Description:

This update for python-numpy fixes the following issues:
Non-security issues fixed:

  • Updated to upstream version 1.16.1. (bsc#1149203) (jsc#SLE-8532)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Python2 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Python2-15-SP1-2019-2462=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2462=1
  • SUSE Linux Enterprise Module for HPC 15-SP1:
    zypper in -t patch SUSE-SLE-Module-HPC-15-SP1-2019-2462=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2462=1

Package List:

  • SUSE Linux Enterprise Module for Python2 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-numpy-debuginfo-1.16.1-4.8.1
    • python-numpy-debugsource-1.16.1-4.8.1
    • python2-numpy-1.16.1-4.8.1
    • python2-numpy-debuginfo-1.16.1-4.8.1
    • python2-numpy-devel-1.16.1-4.8.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (ppc64le s390x):
    • python2-numpy-gnu-hpc-1.16.1-4.8.1
    • python2-numpy-gnu-hpc-devel-1.16.1-4.8.1
    • python3-numpy-gnu-hpc-1.16.1-4.8.1
    • python3-numpy-gnu-hpc-devel-1.16.1-4.8.1
  • SUSE Linux Enterprise Module for HPC 15-SP1 (aarch64 x86_64):
    • python2-numpy-gnu-hpc-1.16.1-4.8.1
    • python2-numpy-gnu-hpc-devel-1.16.1-4.8.1
    • python3-numpy-gnu-hpc-1.16.1-4.8.1
    • python3-numpy-gnu-hpc-devel-1.16.1-4.8.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-numpy-debuginfo-1.16.1-4.8.1
    • python-numpy-debugsource-1.16.1-4.8.1
    • python3-numpy-1.16.1-4.8.1
    • python3-numpy-debuginfo-1.16.1-4.8.1
    • python3-numpy-devel-1.16.1-4.8.1

References: