Security update for bzip2

SUSE Security Update: Security update for bzip2
Announcement ID: SUSE-SU-2019:2013-2
Rating: important
References: #1139083
Cross-References: CVE-2019-12900
Affected Products:
  • SUSE Enterprise Storage 5

An update that fixes one vulnerability is now available.

Description:

This update for bzip2 fixes the following issues:

  • Fixed a regression with the fix for CVE-2019-12900, which caused incompatibilities with files that used many selectors (bsc#1139083).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Enterprise Storage 5:
    zypper in -t patch SUSE-Storage-5-2019-2013=1

Package List:

  • SUSE Enterprise Storage 5 (aarch64):
    • bzip2-1.0.6-30.8.1
    • bzip2-debuginfo-1.0.6-30.8.1
    • bzip2-debugsource-1.0.6-30.8.1
    • libbz2-1-1.0.6-30.8.1
    • libbz2-1-debuginfo-1.0.6-30.8.1
  • SUSE Enterprise Storage 5 (noarch):
    • bzip2-doc-1.0.6-30.8.1

References: