Recommended update for deepsea

SUSE Recommended Update: Recommended update for deepsea
Announcement ID: SUSE-RU-2019:3074-1
Rating: important
References: #1123257 #1134536 #1136066 #1137973 #1141282 #1141285 #1142416 #1145600 #1145617 #1145618 #1148405 #1149405 #1150168 #1150643 #1154096
Affected Products:
  • SUSE Enterprise Storage 6

An update that has 15 recommended fixes can now be installed.

Description:

This update for deepsea fixes the following issues:

  • Fixes an issue that prevented the filestore OSDs from removal through deepsea (bsc#1145600)
  • Fixes an issue where the removal of OSDs from a node ended up in a crash (bsc#1154096, bsc#1141285)
  • Fixes a bug where the iSCSI TPG auth connection gets lost during an upgrade from SUSE Enterprise Storage 5 to SUSE Enterprise Storage 6 (bsc#1145617, bsc#1145618)
  • Fixes an issue where the ceph.conf was updated in the wrong stage when performing an upgrade, which could lead to Ganesha not starting anymore (bsc#1150643)
  • Fixes an issue for Ganesha where an upgrade was performed on a fresh node (bsc#1148405)
  • Prevents IOLoop error by calling Salt modules correctly (bsc#1123257)
  • deepsea is now able to deal with a disabled AppArmor during boot (bsc#1149405)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2019-3074=1

Package List:

  • SUSE Enterprise Storage 6 (noarch):
    • deepsea-0.9.26+git.0.1264f6c3b-3.6.2
    • deepsea-cli-0.9.26+git.0.1264f6c3b-3.6.2

References: