Recommended update for yast2, yast2-packager

SUSE Recommended Update: Recommended update for yast2, yast2-packager
Announcement ID: SUSE-RU-2019:2324-1
Rating: moderate
References: #1132748 #1148536
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15-SP1
  • SUSE Linux Enterprise Installer 15-SP1

An update that has two recommended fixes can now be installed.

Description:

This update for yast2, yast2-packager provides the following fixes:
Changes in yast2:

  • Include the package in the INSTALLER repository to be upgraded during installation.
  • No source changes

Changes in yast2-packager:
  • Avoid error when generating some warnings. (bsc#1148536)
  • Always set proper release version for newly added repositories. (bsc#1132748)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2324=1
  • SUSE Linux Enterprise Installer 15-SP1:
    zypper in -t patch SUSE-SLE-INSTALLER-15-SP1-2019-2324=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • yast2-4.1.72-3.8.1
    • yast2-logs-4.1.72-3.8.1
    • yast2-packager-4.1.49-3.14.2
  • SUSE Linux Enterprise Installer 15-SP1 (aarch64 ppc64le s390x x86_64):
    • yast2-4.1.72-3.8.1
    • yast2-packager-4.1.49-3.14.2

References: