Recommended update for libica

SUSE Recommended Update: Recommended update for libica
Announcement ID: SUSE-RU-2019:1999-1
Rating: moderate
References: #1134004
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP4
  • SUSE Linux Enterprise Server 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for libica fixes the following issues:

  • Reworked how libica-tools loads and unloads kernel modules to avoid spurious error messages. (bsc#1134004) Converted the boot.z90crypt sysV init script to a systemd unit file. Removed any references to insserv in the spec file. Updated the z90crypt script itself to properly load and unload the kernel modules as they exist today.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 12-SP4:
    zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1999=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1999=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 12-SP4 (s390x):
    • libica-debugsource-3.3.3-5.3.1
    • libica-devel-3.3.3-5.3.1
    • libica-devel-static-3.3.3-5.3.1
  • SUSE Linux Enterprise Server 12-SP4 (s390x):
    • libica-debugsource-3.3.3-5.3.1
    • libica-tools-3.3.3-5.3.1
    • libica-tools-debuginfo-3.3.3-5.3.1
    • libica3-3.3.3-5.3.1
    • libica3-32bit-3.3.3-5.3.1
    • libica3-debuginfo-3.3.3-5.3.1
    • libica3-debuginfo-32bit-3.3.3-5.3.1

References: