Recommended update for systemtap

SUSE Recommended Update: Recommended update for systemtap
Announcement ID: SUSE-RU-2019:14041-1
Rating: moderate
References: #1060073 #1131394
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4-LTSS
  • SUSE Linux Enterprise Point of Sale 11-SP3
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that has two recommended fixes can now be installed.

Description:


This update for systemtap provides the following fix:
systemtap was upgraded to version 1.8 (FATE#324284 bsc#1131394)
Changelog:

  • v1.8: https://sourceware.org/ml/systemtap/2012-q2/msg00277.html
  • v1.7: https://sourceware.org/ml/systemtap/2012-q1/msg00097.html
  • v1.6: https://sourceware.org/ml/systemtap/2011-q3/msg00105.html

Additional fixes:
  • Fix argv access on newer kernels (bsc#1060073)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4-LTSS:
    zypper in -t patch slessp4-systemtap-14041=1
  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-systemtap-14041=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-systemtap-14041=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4-LTSS (i586 ppc64 s390x x86_64):
    • systemtap-1.8-0.9.8.1
    • systemtap-server-1.8-0.9.8.1
  • SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
    • systemtap-1.8-0.9.8.1
    • systemtap-server-1.8-0.9.8.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • systemtap-debuginfo-1.8-0.9.8.1
    • systemtap-debugsource-1.8-0.9.8.1

References: