Recommended update for yast2-pkg-bindings

SUSE Recommended Update: Recommended update for yast2-pkg-bindings
Announcement ID: SUSE-RU-2019:0938-1
Rating: moderate
References: #1094468 #1097756
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15
  • SUSE Linux Enterprise Installer 15

An update that has two recommended fixes can now be installed.

Description:

This update for yast2-pkg-bindings fixes the following issues:

  • Does no longer save plugin services to the target system (bsc#1094468)
  • Fixes an error when saving services during an upgrade (bsc#1097756)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-938=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-938=1
  • SUSE Linux Enterprise Installer 15:
    zypper in -t patch SUSE-SLE-INSTALLER-15-2019-938=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • yast2-pkg-bindings-devel-doc-4.0.13-3.5.56
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • yast2-pkg-bindings-4.0.13-3.5.56
    • yast2-pkg-bindings-debuginfo-4.0.13-3.5.56
    • yast2-pkg-bindings-debugsource-4.0.13-3.5.56
  • SUSE Linux Enterprise Installer 15 (aarch64 ppc64le s390x x86_64):
    • yast2-pkg-bindings-4.0.13-3.5.56

References: