Recommended update for crowbar packages

SUSE Recommended Update: Recommended update for crowbar packages
Announcement ID: SUSE-RU-2019:0584-1
Rating: moderate
References: #1112767 #1113107
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8

An update that has two recommended fixes can now be installed.

Description:

This update provides crowbar fixes for the following issues:
crowbar:

  • Upgrade: rabbitmq and epmd packages need to go in the right order

crowbar-core:
  • Upgrade: Create update repositories with refresh enabled
  • Upgrade: Delay status switch after upgrade ends
  • Fix hound warning
  • Support RAID 0
  • Package default upgrade timeouts file
  • apache2: enable sslsessioncache
  • upgrade: Update the repository names required for SOC9
  • upgrade: Check for the correct file indicating postponed upgrade
  • upgrade: Block access to crowbar UI for both upgrade paths
  • upgrade: Add default upgrade timeouts file
  • upgrade: Call heat's migrate_properties_data after the upgrade
  • upgrade: Call nova online migration in a loop
  • upgrade: Restart nova-compute instead of relaoding via SIGHUP
  • upgrade: Let the upgrade library work with both 7-8 and 8-9 upgrades
  • upgrade: Fix check for ceph presence
  • upgrade: Map jsonapi for respond_to
  • upgrade: Finish only controllers step

crowbar-ceph:
  • Adapt radosgw to keystone v3
  • switch to stable/5.0-pike branch
  • radosgw: Generate slightly saner root RSA key
  • radosgw: Restart radosgw on cert (re-)creation

crowbar-openstack:
  • ceilometer: Use pacemaker to handle expirer cron link (bsc#1113107)
  • mysql: Do not set a custom logfile for mysqld (bsc#1112767)
  • mariadb: Remove installing the xtrabackup package
  • mysql: create .my.cnf in root home directory for mysql cmdline
  • neutron: scale up api workers on larger core envs
  • database: Fix backport schema migrations actualy safe for backporting

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-584=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • crowbar-5.0+git.1548680871.201d7a49-3.9.1
    • crowbar-ceph-5.0+git.1546538227.6c6cde9-3.1
    • crowbar-devel-5.0+git.1548680871.201d7a49-3.9.1
    • crowbar-openstack-5.0+git.1550668971.0719acd6c-4.19.1
  • SUSE OpenStack Cloud Crowbar 8 (x86_64):
    • crowbar-core-5.0+git.1550057516.5fa11ed35-3.17.1
    • crowbar-core-branding-upstream-5.0+git.1550057516.5fa11ed35-3.17.1

References: