Recommended update for python packages

SUSE Recommended Update: Recommended update for python packages
Announcement ID: SUSE-RU-2019:0411-1
Rating: moderate
References: #1115904 #1123054
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 8
  • HPE Helion Openstack 8

An update that has two recommended fixes can now be installed.

Description:

This update for python fixes the following issues:
python-amqp:

  • Add patch Always-treat-SSLError-timeouts-as-socket-timeouts-24. (bsc#1115904)
  • Add fdupes to specfile
  • Sending empty messages no longer hangs. Instead an empty message is sent correctly. (bsc#1123054)
  • Fixed compatibility issues in UTF-8 encoding behavior between Py2/Py3
  • Fix implicit conversion from bytes to string on the connection object. (Issue #155) This issue has caused Celery to crash on connection to RabbitMQ.
  • Fix random delays in task execution. This is a bug that caused performance issues due to polling timeouts that occur when receiving incomplete AMQP frames.
  • Calling "conn.collect()" multiple times will no longer raise an "AttributeError" when no channels exist.
  • Fix compatibility code for Python 2.7.6.
  • When running in Windows, py-amqp will no longer use the unsupported TCP option TCP_MAXSEG.
  • Added support for setting the SNI hostname header. The SSL protocol version is now set to SSLv23
  • Authentication mechanisms were refactored to be more modular. GSSAPI authentication is now supported.
  • Do not reconnect on collect.

python-kombu:
  • RabbitMQ: Ensured safer encoding of queue arguments.
  • Added fallback to :func:``uuid.uuid5`` in :func:``generate_oid`` if
  • Added Python 3.6 to CI testing
  • Fixed bug around modifying dictionary size while iterating over it

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-411=1
  • SUSE OpenStack Cloud 8:
    zypper in -t patch SUSE-OpenStack-Cloud-8-2019-411=1
  • HPE Helion Openstack 8:
    zypper in -t patch HPE-Helion-OpenStack-8-2019-411=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • python-amqp-2.2.2-3.3.1
    • python-kombu-4.1.0-3.3.1
  • SUSE OpenStack Cloud 8 (noarch):
    • python-amqp-2.2.2-3.3.1
    • python-kombu-4.1.0-3.3.1
  • HPE Helion Openstack 8 (noarch):
    • python-amqp-2.2.2-3.3.1
    • python-kombu-4.1.0-3.3.1

References: