Recommended update for python-oslo packages

SUSE Recommended Update: Recommended update for python-oslo packages
Announcement ID: SUSE-RU-2019:0409-1
Rating: moderate
References: #1109756
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 8
  • HPE Helion Openstack 8

An update that has one recommended fix can now be installed.

Description:

This update for python-oslo packages fixes the following issues:
python-oslo.messaging:

  • Do not access the connection's socket during error callback
  • Avoid reconnect to the same AMQP server while trying to error handle the original server error (bsc#1109756)
  • Avoid logging passwords on connection events
  • import zuul job settings from project-config
  • Suppress excessive debug logs when consume rabbit
  • Revert "rabbit: Don't prefetch when batch\_size is set"
  • Use stable branch for upper constraints
  • Create doc/requirements.txt
  • Avoid tox\_install.sh for constraints support

python-oslo.policy:
  • Fix sphinx-docs job for stable branch
  • Avoid redundant policy syntax checks

python-oslo.utils
  • Fix sphinx-docs job for stable branch
  • Add private_key to the list of sanitized keys

python-oslo.versionedobjects:
  • Use stable branch for upper constraints
  • Fixing UUID coerce function for unicode non uuid form
  • Don't force unicode strings for UUID coercion
  • Avoid tox_install.sh for constraints support
  • Follow the new PTI for document build

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-409=1
  • SUSE OpenStack Cloud 8:
    zypper in -t patch SUSE-OpenStack-Cloud-8-2019-409=1
  • HPE Helion Openstack 8:
    zypper in -t patch HPE-Helion-OpenStack-8-2019-409=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • python-oslo.messaging-5.30.7-3.5.1
    • python-oslo.policy-1.25.3-3.3.1
    • python-oslo.utils-3.28.3-3.3.1
    • python-oslo.versionedobjects-1.26.2-3.3.2
  • SUSE OpenStack Cloud 8 (noarch):
    • python-oslo.messaging-5.30.7-3.5.1
    • python-oslo.policy-1.25.3-3.3.1
    • python-oslo.utils-3.28.3-3.3.1
    • python-oslo.versionedobjects-1.26.2-3.3.2
  • HPE Helion Openstack 8 (noarch):
    • python-oslo.messaging-5.30.7-3.5.1
    • python-oslo.policy-1.25.3-3.3.1
    • python-oslo.utils-3.28.3-3.3.1
    • python-oslo.versionedobjects-1.26.2-3.3.2

References: