Recommended update for aws-cli, python-boto3, python-botocore

SUSE Recommended Update: Recommended update for aws-cli, python-boto3, python-botocore
Announcement ID: SUSE-RU-2019:0399-1
Rating: moderate
References: #1118024
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 8
  • SUSE Linux Enterprise Module for Public Cloud 12
  • HPE Helion Openstack 8

An update that has one recommended fix can now be installed.

Description:

This update for aws-cli, python-boto3, python-botocore fixes the following issues:

  • Update aws-cli to version 1.16.61 (bsc#1118024)
  • Update python-botocore to version 1.12.57 (bsc#1118024)
  • Update python-boto3 to version 1.9.57 (bsc#1118024)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-399=1
  • SUSE OpenStack Cloud 8:
    zypper in -t patch SUSE-OpenStack-Cloud-8-2019-399=1
  • SUSE Linux Enterprise Module for Public Cloud 12:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-12-2019-399=1
  • HPE Helion Openstack 8:
    zypper in -t patch HPE-Helion-OpenStack-8-2019-399=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • aws-cli-1.16.61-22.3.1
    • python-botocore-1.12.57-28.6.1
  • SUSE OpenStack Cloud 8 (noarch):
    • aws-cli-1.16.61-22.3.1
    • python-botocore-1.12.57-28.6.1
  • SUSE Linux Enterprise Module for Public Cloud 12 (noarch):
    • aws-cli-1.16.61-22.3.1
    • python-boto3-1.9.57-14.3.1
    • python-botocore-1.12.57-28.6.1
  • HPE Helion Openstack 8 (noarch):
    • aws-cli-1.16.61-22.3.1
    • python-botocore-1.12.57-28.6.1

References: