Security update for openssh-openssl1

SUSE Security Update: Security update for openssh-openssl1
Announcement ID: SUSE-SU-2018:3768-1
Rating: moderate
References: #1091396 #1105010 #1106163 #964336
Cross-References: CVE-2018-15473 CVE-2018-15919
Affected Products:
  • SUSE Linux Enterprise Server 11-SECURITY

An update that solves two vulnerabilities and has two fixes is now available.

Description:

This update for openssh-openssl1 fixes the following issues:
Security issues fixed:

  • CVE-2018-15919: Remotely observable behaviour in auth-gss2.c in OpenSSH could be used by remote attackers to detect existence of users on a target system when GSS2 is in use. OpenSSH developers do not want to treat such a username enumeration (or "oracle") as a vulnerability. (bsc#1106163)
  • CVE-2018-15473: OpenSSH was prone to a user existance oracle vulnerability due to not delaying bailout for an invalid authenticating user until after the packet containing the request has been fully parsed, related to auth2-gss.c, auth2-hostbased.c, and auth2-pubkey.c. (bsc#1105010)

Following non-security issues were fixed:
  • Fix for sftp client because it returns wrong error code upon failure (bsc#1091396)
  • Stop leaking File descriptors (bsc#964336)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SECURITY:
    zypper in -t patch secsp3-openssh-openssl1-13865=1

Package List:

  • SUSE Linux Enterprise Server 11-SECURITY (i586 ia64 ppc64 s390x x86_64):
    • openssh-openssl1-6.6p1-19.6.1
    • openssh-openssl1-helpers-6.6p1-19.6.1

References: