Upstream information

CVE-2018-15473 at MITRE

Description

OpenSSH through 7.7 is prone to a user enumeration vulnerability due to not delaying bailout for an invalid authenticating user until after the packet containing the request has been fully parsed, related to auth2-gss.c, auth2-hostbased.c, and auth2-pubkey.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 5.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3 3.1
SUSE Bugzilla entries: 1105010 [RESOLVED / FIXED], 1106163 [RESOLVED / WONTFIX], 1123133 [RESOLVED / FIXED], 1138392 [RESOLVED / FIXED], 1205621 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-Azure-BYOS
Image SLES15-EC2-CHOST-HVM-BYOS
Image SLES15-EC2-HVM-BYOS
Image SLES15-GCE-BYOS
Image SLES15-OCI-BYOS
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
  • openssh >= 7.6p1-9.3.1
SUSE CaaS Platform 3.0
  • openssh >= 7.2p2-74.30.1
Patchnames:
SUSE-CAASP-3.0-2018-2783
SUSE Enterprise Storage 4
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-Storage-4-2018-2783
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • openssh >= 7.9p1-4.7
  • openssh-fips >= 7.9p1-4.7
  • openssh-helpers >= 7.9p1-4.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA openssh-7.9p1-4.7
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA openssh-fips-7.9p1-4.7
SUSE Linux Enterprise Desktop 12 SP3
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-2783
SUSE Linux Enterprise Desktop 12 SP4
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2018-2783
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • openssh >= 7.9p1-4.7
  • openssh-helpers >= 7.9p1-4.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA openssh-7.9p1-4.7
SUSE Linux Enterprise Desktop 15
  • openssh >= 7.6p1-9.3.1
  • openssh-askpass-gnome >= 7.6p1-9.3.1
  • openssh-helpers >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2619
SUSE-SLE-Module-Desktop-Applications-15-2018-2619
SUSE Linux Enterprise High Performance Computing 12 SP5
  • openssh >= 7.2p2-74.45.1
  • openssh-fips >= 7.2p2-74.45.1
  • openssh-helpers >= 7.2p2-74.45.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA openssh-7.2p2-74.45.1
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • openssh >= 7.6p1-9.3.1
  • openssh-askpass-gnome >= 7.6p1-9.3.1
  • openssh-fips >= 7.6p1-9.3.1
  • openssh-helpers >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2619
SUSE-SLE-Module-Desktop-Applications-15-2018-2619
SUSE-SLE-Module-Server-Applications-15-2018-2619
SUSE Linux Enterprise Module for Basesystem 15
  • openssh >= 7.6p1-9.3.1
  • openssh-helpers >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-2619
SUSE Linux Enterprise Module for Desktop Applications 15
  • openssh-askpass-gnome >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2619
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • openssh-fips >= 7.9p1-4.7
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP1 GA openssh-fips-7.9p1-4.7
SUSE Linux Enterprise Module for Server Applications 15
  • openssh-fips >= 7.6p1-9.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2018-2619
SUSE Linux Enterprise Point of Sale 11 SP3
  • openssh >= 6.2p2-0.41.5.1
  • openssh-askpass >= 6.2p2-0.41.5.1
  • openssh-askpass-gnome >= 6.2p2-0.41.5.1
Patchnames:
sleposp3-openssh-13848
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-2783
SUSE Linux Enterprise Server 11 SP3-LTSS
  • openssh >= 6.2p2-0.41.5.1
  • openssh-askpass >= 6.2p2-0.41.5.1
  • openssh-askpass-gnome >= 6.2p2-0.41.5.1
Patchnames:
slessp3-openssh-13848
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • openssh >= 6.6p1-36.6.1
  • openssh-askpass-gnome >= 6.6p1-36.6.1
  • openssh-fips >= 6.6p1-36.6.1
  • openssh-helpers >= 6.6p1-36.6.1
Patchnames:
slessp4-openssh-13867
SUSE Linux Enterprise Server 11-SECURITY
  • openssh-openssl1 >= 6.6p1-19.6.1
  • openssh-openssl1-helpers >= 6.6p1-19.6.1
Patchnames:
secsp3-openssh-openssl1-13865
SUSE Linux Enterprise Server 12 SP1-LTSS
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-2698
SUSE Linux Enterprise Server 12 SP2-BCL
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-2783
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-2783
SUSE Linux Enterprise Server 12 SP2-LTSS
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-2783
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-2783
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2018-2783
SUSE Linux Enterprise Server 12 SP5
  • openssh >= 7.2p2-74.45.1
  • openssh-fips >= 7.2p2-74.45.1
  • openssh-helpers >= 7.2p2-74.45.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA openssh-7.2p2-74.45.1
SUSE Linux Enterprise Server 12-LTSS
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SERVER-12-2018-2698
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • openssh >= 6.6p1-54.18.1
  • openssh-askpass-gnome >= 6.6p1-54.18.1
  • openssh-fips >= 6.6p1-54.18.1
  • openssh-helpers >= 6.6p1-54.18.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1081
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-2783
SUSE OpenStack Cloud 7
  • openssh >= 7.2p2-74.30.1
  • openssh-askpass-gnome >= 7.2p2-74.30.1
  • openssh-fips >= 7.2p2-74.30.1
  • openssh-helpers >= 7.2p2-74.30.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-2783
SUSE Package Hub 15 SP3
  • ssh-audit >= 2.5.0-bp153.2.3.1
Patchnames:
openSUSE-2021-1390
openSUSE Leap 15.0
  • openssh >= 7.6p1-lp150.8.3.1
  • openssh-askpass-gnome >= 7.6p1-lp150.8.3.1
  • openssh-cavs >= 7.6p1-lp150.8.3.1
  • openssh-fips >= 7.6p1-lp150.8.3.1
  • openssh-helpers >= 7.6p1-lp150.8.3.1
Patchnames:
openSUSE-2019-914
openSUSE Leap 15.2
  • ssh-audit >= 2.5.0-lp152.2.3.1
Patchnames:
openSUSE-2021-1383
openSUSE Leap 15.3
  • ssh-audit >= 2.5.0-bp153.2.3.1
Patchnames:
openSUSE-2021-1390
openSUSE Tumbleweed
  • ssh-audit >= 2.5.0-1.2
Patchnames:
openSUSE Tumbleweed GA ssh-audit-2.5.0-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 openssh Released
SUSE Linux Enterprise High Performance Computing 12 SP5 openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12 SP5 openssh Released
SUSE Linux Enterprise Server 12 SP5 openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12-LTSS openssh Released
SUSE Linux Enterprise Server 12-LTSS openssh-askpass-gnome Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 openssh-askpass-gnome Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS openssh Released
SUSE Linux Enterprise High Performance Computing 12 SP4 openssh Already fixed
SUSE Linux Enterprise High Performance Computing 15 openssh Released
SUSE Linux Enterprise High Performance Computing 15 openssh-askpass-gnome Released
SUSE Linux Enterprise High Performance Computing 15-ESPOS openssh Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS openssh Affected
SUSE Linux Enterprise Server 12 SP2-BCL openssh Released
SUSE Linux Enterprise Server 12 SP2-BCL openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12 SP4 openssh Released
SUSE Linux Enterprise Server 12 SP4 openssh-askpass-gnome Released
SUSE Linux Enterprise Server 15-ESPOS openssh Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openssh-askpass-gnome Released
SUSE Linux Enterprise Server for SAP Applications 15 openssh Released
SUSE Linux Enterprise Server for SAP Applications 15 openssh-askpass-gnome Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 openssh Released
HPE Helion OpenStack 8 openssh-askpass-gnome Affected
Magnum Orchestration 7 openssh Already fixed
SLES for SAP Applications 11 SP3 openssh Already fixed
SUSE CaaS Platform 3.0 openssh Released
SUSE Container as a Service Platform 1.0 openssh Affected
SUSE Container as a Service Platform 2.0 openssh Already fixed
SUSE Enterprise Storage 4 openssh Released
SUSE Enterprise Storage 4 openssh-askpass-gnome Released
SUSE Enterprise Storage 5 openssh Released
SUSE Linux Enterprise Desktop 12 openssh Affected
SUSE Linux Enterprise Desktop 12 SP1 openssh Affected
SUSE Linux Enterprise Desktop 12 SP2 openssh Affected
SUSE Linux Enterprise Desktop 12 SP2 openssh-askpass-gnome Affected
SUSE Linux Enterprise Desktop 12 SP3 openssh Released
SUSE Linux Enterprise Desktop 12 SP3 openssh-askpass-gnome Released
SUSE Linux Enterprise Desktop 12 SP4 openssh Released
SUSE Linux Enterprise Desktop 12 SP4 openssh-askpass-gnome Released
SUSE Linux Enterprise Desktop 15 openssh Released
SUSE Linux Enterprise Desktop 15 openssh-askpass-gnome Released
SUSE Linux Enterprise Module for Basesystem 15 openssh Released
SUSE Linux Enterprise Module for Desktop Applications 15 openssh-askpass-gnome Released
SUSE Linux Enterprise Module for Server Applications 15 openssh Released
SUSE Linux Enterprise Point of Sale 11 SP3 openssh Released
SUSE Linux Enterprise Point of Sale 11 SP3 openssh-askpass-gnome Released
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT openssh Released
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT openssh-askpass-gnome Released
SUSE Linux Enterprise Point of Service 11 SP3 openssh Affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 openssh Released
SUSE Linux Enterprise Server 11 SP3 openssh Affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssh Released
SUSE Linux Enterprise Server 11 SP3-LTSS openssh Released
SUSE Linux Enterprise Server 11 SP3-LTSS openssh-askpass-gnome Released
SUSE Linux Enterprise Server 11 SP4 openssh Released
SUSE Linux Enterprise Server 11 SP4 openssh-askpass-gnome Released
SUSE Linux Enterprise Server 11 SP4 LTSS openssh Affected
SUSE Linux Enterprise Server 11 SP4-LTSS openssh Affected
SUSE Linux Enterprise Server 11-SECURITY openssh-openssl1 Released
SUSE Linux Enterprise Server 12 openssh Affected
SUSE Linux Enterprise Server 12 SP1 openssh Affected
SUSE Linux Enterprise Server 12 SP1-LTSS openssh Released
SUSE Linux Enterprise Server 12 SP1-LTSS openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12 SP2 openssh Affected
SUSE Linux Enterprise Server 12 SP2 openssh-askpass-gnome Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS openssh Released
SUSE Linux Enterprise Server 12 SP2-ESPOS openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12 SP2-LTSS openssh Released
SUSE Linux Enterprise Server 12 SP2-LTSS openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12 SP3 openssh Released
SUSE Linux Enterprise Server 12 SP3 openssh-askpass-gnome Released
SUSE Linux Enterprise Server 12 SP3-BCL openssh Released
SUSE Linux Enterprise Server 12 SP3-BCL openssh-askpass-gnome Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS openssh Released
SUSE Linux Enterprise Server 12 SP3-ESPOS openssh-askpass-gnome Affected
SUSE Linux Enterprise Server 12 SP3-LTSS openssh Released
SUSE Linux Enterprise Server 12 SP3-LTSS openssh-askpass-gnome Affected
SUSE Linux Enterprise Server 15 openssh Released
SUSE Linux Enterprise Server 15 openssh-askpass-gnome Released
SUSE Linux Enterprise Server 15-LTSS openssh Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 openssh Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 openssh-askpass-gnome Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 openssh Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 openssh-askpass-gnome Released
SUSE Linux Enterprise Server for SAP Applications 12 openssh Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP1 openssh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 openssh-askpass-gnome Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openssh-askpass-gnome Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssh-askpass-gnome Released
SUSE OpenStack Cloud 7 openssh Released
SUSE OpenStack Cloud 7 openssh-askpass-gnome Released
SUSE OpenStack Cloud 8 openssh Released
SUSE OpenStack Cloud 8 openssh-askpass-gnome Affected
SUSE OpenStack Cloud Crowbar 8 openssh Released
SUSE OpenStack Cloud Crowbar 8 openssh-askpass-gnome Affected
SUSE Package Hub 15 SP3 ssh-audit Released
Security Module for SUSE Linux Enterprise 11 openssh-openssl1 Released


SUSE Timeline for this CVE

CVE page created: Tue Oct 9 01:15:09 2018
CVE page last modified: Tue Jan 17 17:51:31 2023