Recommended update for pacemaker

SUSE Recommended Update: Recommended update for pacemaker
Announcement ID: SUSE-RU-2018:3651-1
Rating: moderate
References: #1022807 #1024037 #1035822 #1042054 #1053463 #980341
Affected Products:
  • SUSE Linux Enterprise High Availability Extension 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that has 6 recommended fixes can now be installed.

Description:

This update for pacemaker provides the following fix:

  • cib: Broadcasts of cib changes should always pass ACLs check. (bsc#1042054)
  • liblrmd: Make sure the operation of a remote resource returns if setup of the key fails (bsc#1053463)
  • Correctly handle xml comments (bsc#1024037)
  • spec: Prevent overwriting existing sysconfig files by conditionally running %fillup_only (bsc#1022807, bsc#980341)
  • lrmd: prevent double free after unregistering stonith device for monitoring (bsc#1035822)
  • crmd: Ack pending operations that were cancelled due to rsc deletion (bsc#1035822)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability Extension 11-SP4:
    zypper in -t patch slehasp4-pacemaker-13858=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-pacemaker-13858=1

Package List:

  • SUSE Linux Enterprise High Availability Extension 11-SP4 (i586 ia64 ppc64 s390x x86_64):
    • libpacemaker-devel-1.1.12-19.5.1
    • libpacemaker3-1.1.12-19.5.1
    • pacemaker-1.1.12-19.5.1
    • pacemaker-cli-1.1.12-19.5.1
    • pacemaker-remote-1.1.12-19.5.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):
    • pacemaker-debuginfo-1.1.12-19.5.1
    • pacemaker-debugsource-1.1.12-19.5.1

References: