SUSE Support

Here When You Need Us

During the upgrade from SES 5.5 to SES 6 the command "ceph-volume simple scan" returns errors

This document (000019814) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 5.5
SUSE Enterprise Storage 6

Situation

As per the SES 6 upgrade documentation it is required to run the following command during the upgrade procedure:
 
ceph-volume simple scan --force

This succeeds, but reports errors similar to the following example during execution:
stderr: lsblk: /var/lib/ceph/osd/ceph-111: not a block device
stderr: Unknown device, --name=, --path=, or absolute path in /dev/ or /sys expected.
Running command: /usr/sbin/cryptsetup status /dev/sdh1
--> OSD 111 got scanned and metadata persisted to file: /etc/ceph/osd/111-533ga700-cdc9-171g-b1dg-7a5f1fxe5e5c.json
--> To take over managment of this scanned OSD, and disable ceph-disk and udev, run:
--> ceph-volume simple activate 111 533ga700-cdc9-171g-b1dg-7a5f1fxe5e5c

Resolution

The errors are cosmetic and can be ignored.

Cause

The "ceph-volume simple scan" command attempts to run lslkb also against all the mounted OSD directories at "/var/lib/ceph/osd/ceph-$ID".

Additional Information

To verify the command completed successfully, there should be a json file for each OSD (Object Storage Daemon) on the host in "/etc/ceph/osd/". The json files will start with the relevant OSD number, for example if we had OSDs 3, 6, 10 and 13 running on the host the files should look similar to:

10-04b9c3b5-a553-47f1-b925-68653115176c.json
13-4038c101-7985-41b5-b5ff-8ee719d9f55e.json
3-dab08891-6837-40cb-bfa9-2f2bb9dd99c3.json
6-95cf6ab8-ebfc-45d2-a661-e59877db5430.json

Each file should contain proper device information for the relevant OSD ID.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019814
  • Creation Date: 16-Dec-2020
  • Modified Date:16-Dec-2020
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.