SUSE Support

Here When You Need Us

lrbd fails to start with: "ERROR: list index out of range"

This document (7018736) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Enterprise Storage 4

Situation

When attempting to start the iSCSI gateway (lrbd) this fails with the following:

Traceback (most recent call last):
  File "/usr/sbin/lrbd", line 2834, in <module>
    main(args)
  File "/usr/sbin/lrbd", line 2760, in main
    iscsi = Iscsi()
  File "/usr/sbin/lrbd", line 1353, in __init__
    wwn.generate(self.iqns)
  File "/usr/sbin/lrbd", line 1462, in generate
    self._save(pentry, entry, target, _uuid)
  File "/usr/sbin/lrbd", line 1480, in _save
    vus = open(path[0], "w")
IndexError: list index out of range

Resolution

Make sure the lrbd.service is not disabled but set to start during boot.

To verify the status:

systemctl is-enabled lrbd.service

To change the status:

systemctl enable lrbd.service

Cause

Should the RBD kernel module be loaded manually or outside of rbd map, it by default loads with single major (single_major) support DISABLED which then can result in the expected range of majors to be overrun resulting in the error.

Additional Information

An alternative solution if it is desired to manually start the lrbd.service, is to force the RBD kernel module to load with single major support enabled at all times by taking the following steps:

- Edit "/etc/modprobe.d/99-local.conf" and add the line: options rbd single_major=Y
- Recreate the initrd so it includes the modified file by executing: mkinitrd
- Reboot the node.

To verify the current setting execute the below which should return "Y" eg. enabled:

:~ # cat /sys/module/rbd/parameters/single_major
Y

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7018736
  • Creation Date: 24-Mar-2017
  • Modified Date:03-Mar-2020
    • SUSE Enterprise Storage

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.