Upstream information

CVE-2022-42004 at MITRE

Description

In FasterXML jackson-databind before 2.13.4, resource exhaustion can occur because of a lack of a check in BeanDeserializer._deserializeFromArray to prevent use of deeply nested arrays. An application is vulnerable only with certain customized choices for deserialization.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1204369 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
  • jackson-databind >= 2.13.4.2-150200.3.12.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • jackson-databind >= 2.13.4.2-150200.3.12.1
  • jackson-databind-javadoc >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-3995
SUSE-SLE-Module-Development-Tools-15-SP3-2022-3995
SUSE Enterprise Storage 7
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-Storage-7-2022-3995
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2022-3995
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-ESPOS-2022-3995
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP2-LTSS-2022-3995
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • jackson-databind >= 2.13.4.2-150200.3.12.1
  • jackson-databind-javadoc >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2022-3995
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-3995
SUSE Linux Enterprise Server 15 SP2-BCL
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-BCL-2022-3995
SUSE Linux Enterprise Server 15 SP2-LTSS
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-3995
SUSE Linux Enterprise Server for SAP Applications 15 SP2
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP2-2022-3995
SUSE Manager Proxy 4.1
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-3995
SUSE Manager Retail Branch Server 4.1
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-3995
SUSE Manager Server 4.1
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-3995
SUSE Manager Server Module 4.3
  • jackson-databind >= 2.13.4.2-150200.3.12.1
Patchnames:
SUSE-SLE-Module-SUSE-Manager-Server-4.3-2022-3995
openSUSE Leap 15.3
  • jackson-databind >= 2.13.4.2-150200.3.12.1
  • jackson-databind-javadoc >= 2.13.4.2-150200.3.12.1
Patchnames:
openSUSE-SLE-15.3-2022-3995
openSUSE Leap 15.4
  • jackson-databind >= 2.13.4.2-150200.3.12.1
  • jackson-databind-javadoc >= 2.13.4.2-150200.3.12.1
Patchnames:
openSUSE-SLE-15.4-2022-3995
openSUSE Tumbleweed
  • jackson-databind >= 2.13.4.2-1.1
  • jackson-databind-javadoc >= 2.13.4.2-1.1
Patchnames:
openSUSE Tumbleweed GA jackson-databind-2.13.4.2-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 jackson-databind Released
SUSE Enterprise Storage 7.1 jackson-databind Released
SUSE Linux Enterprise Desktop 15 SP4 jackson-databind Released
SUSE Linux Enterprise High Performance Computing 15 SP4 jackson-databind Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 jackson-databind Released
SUSE Linux Enterprise Real Time 15 SP3 jackson-databind Affected
SUSE Linux Enterprise Server 15 SP4 jackson-databind Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 jackson-databind Released
SUSE Manager Proxy 4.2 jackson-databind Released
SUSE Manager Proxy 4.3 jackson-databind Released
SUSE Manager Retail Branch Server 4.2 jackson-databind Released
SUSE Manager Retail Branch Server 4.3 jackson-databind Released
SUSE Manager Server 4.2 jackson-databind Released
SUSE Manager Server 4.3 jackson-databind Released
SUSE Manager Server Module 4.3 jackson-databind Released
openSUSE Leap 15.4 jackson-databind Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 jackson-databind Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS jackson-databind Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS jackson-databind Released
SUSE Linux Enterprise High Performance Computing 15 SP3 jackson-databind Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS jackson-databind Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS jackson-databind Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 jackson-databind Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 jackson-databind Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 jackson-databind Released
SUSE Linux Enterprise Server 15 SP2 jackson-databind Affected
SUSE Linux Enterprise Server 15 SP2-LTSS jackson-databind Released
SUSE Linux Enterprise Server 15 SP3 jackson-databind Released
SUSE Linux Enterprise Server 15 SP3-LTSS jackson-databind Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 jackson-databind Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 jackson-databind Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 jackson-databind Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 15 SP2 jackson-databind Affected
SUSE Linux Enterprise Desktop 15 SP3 jackson-databind Released
SUSE Linux Enterprise Real Time 15 SP2 jackson-databind Affected
SUSE Linux Enterprise Server 15 SP2-BCL jackson-databind Released
SUSE Linux Enterprise Server 15 SP3-BCL jackson-databind Affected
SUSE Manager Proxy 4.1 jackson-databind Released
SUSE Manager Retail Branch Server 4.1 jackson-databind Released
SUSE Manager Server 4.1 jackson-databind Released


SUSE Timeline for this CVE

CVE page created: Sun Oct 2 14:00:25 2022
CVE page last modified: Sat Jan 21 12:18:12 2023