Upstream information

CVE-2022-40899 at MITRE

Description

An issue discovered in Python Charmers Future 0.18.2 and earlier allows remote attackers to cause a denial of service via crafted Set-Cookie header from malicious web server.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1206673 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-HPC-BYOS
Image SLES12-SP5-Azure-HPC-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-ECS-On-Demand
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-GCE-BYOS
Image SLES12-SP5-GCE-On-Demand
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
Image SLES15-SP3-Manager-4-2-Server-BYOS-Azure
Image SLES15-SP3-Manager-4-2-Server-BYOS-EC2-HVM
Image SLES15-SP3-Manager-4-2-Server-BYOS-GCE
  • python3-future >= 0.18.2-150300.3.3.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP4-2023-79
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA python-future-0.18.2-150300.3.3.1
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA python3-future-0.18.2-150300.3.3.1
SUSE Linux Enterprise High Performance Computing 12
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python-future >= 0.15.2-3.3.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2023-78
SUSE-SLE-Module-Web-Scripting-12-2023-663
SUSE-SLE-Module-Web-Scripting-12-2023-76
SUSE Linux Enterprise Micro 5.1
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2023-79
SUSE Linux Enterprise Micro 5.2
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2023-79
SUSE Linux Enterprise Micro 5.3
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE-SLE-Micro-5.3-2023-79
SUSE Linux Enterprise Micro 5.4
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE Linux Enterprise Micro 5.4 GA python3-future-0.18.2-150300.3.3.1
SUSE Linux Enterprise Module for Public Cloud 12
  • python-future >= 0.15.2-3.3.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2023-78
SUSE Linux Enterprise Module for Web and Scripting 12
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2023-663
SUSE-SLE-Module-Web-Scripting-12-2023-76
SUSE Linux Enterprise Real Time 15 SP3
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
SUSE-SLE-Product-RT-15-SP3-2023-79
SUSE Linux Enterprise Server 12 SP2-BCL
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2023-663
SUSE Linux Enterprise Server 12 SP4-ESPOS
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2023-663
SUSE Linux Enterprise Server 12 SP4-LTSS
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2023-663
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • libpython3_4m1_0-32bit >= 3.4.10-25.108.1
  • python-future >= 0.15.2-3.3.1
  • python-future >= 0.15.2-3.5.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
  • python3-dbm >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
  • python3-tk >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2023-78
SUSE-SLE-Module-Web-Scripting-12-2023-663
SUSE-SLE-Module-Web-Scripting-12-2023-76
SUSE-SLE-SDK-12-SP5-2023-663
SUSE-SLE-SDK-12-SP5-2023-76
SUSE-SLE-SERVER-12-SP5-2023-663
SUSE-SLE-SERVER-12-SP5-2023-76
SUSE-SLE-SERVER-12-SP5-2023-80
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python-future >= 0.15.2-3.3.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2023-78
SUSE-SLE-Module-Web-Scripting-12-2023-663
SUSE-SLE-Module-Web-Scripting-12-2023-76
SUSE-SLE-SAP-12-SP4-2023-663
SUSE Linux Enterprise Software Development Kit 12 SP5
  • python3-dbm >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-663
SUSE-SLE-SDK-12-SP5-2023-76
SUSE OpenStack Cloud 9
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
Patchnames:
SUSE-OpenStack-Cloud-9-2023-663
SUSE OpenStack Cloud Crowbar 9
  • libpython3_4m1_0 >= 3.4.10-25.108.1
  • python3 >= 3.4.10-25.108.1
  • python3-base >= 3.4.10-25.108.1
  • python3-curses >= 3.4.10-25.108.1
  • python3-devel >= 3.4.10-25.108.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2023-663
openSUSE Leap 15.4
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
openSUSE-SLE-15.4-2023-79
openSUSE Leap Micro 5.2
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
openSUSE-Leap-Micro-5.2-2023-79
openSUSE Leap Micro 5.3
  • python3-future >= 0.18.2-150300.3.3.1
Patchnames:
openSUSE-Leap-Micro-5.3-2023-79
openSUSE Tumbleweed
  • python310-future >= 0.18.2-4.1
  • python38-future >= 0.18.2-4.1
  • python39-future >= 0.18.2-4.1
Patchnames:
openSUSE Tumbleweed GA python310-future-0.18.2-4.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SLES15-SP5-CHOST-BYOS-Aliyun python3 Not affected
SLES15-SP5-CHOST-BYOS-Azure python3 Not affected
SLES15-SP5-CHOST-BYOS-EC2 python3 Not affected
SLES15-SP5-CHOST-BYOS-GCE python3 Not affected
SLES15-SP5-CHOST-BYOS-SAP-CCloud python3 Not affected
SUSE Enterprise Storage 7.1 python Not affected
SUSE Enterprise Storage 7.1 python-future Released
SUSE Enterprise Storage 7.1 python3 Not affected
SUSE Enterprise Storage 7.1 python39 Not affected
SUSE Linux Enterprise Desktop 15 SP5 python-future Released
SUSE Linux Enterprise Desktop 15 SP5 python3 Not affected
SUSE Linux Enterprise High Performance Computing 12 python-future Released
SUSE Linux Enterprise High Performance Computing 12 python3 Released
SUSE Linux Enterprise High Performance Computing 12 python3-base Released
SUSE Linux Enterprise High Performance Computing 12 SP5 python Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 python-future Released
SUSE Linux Enterprise High Performance Computing 12 SP5 python3 Released
SUSE Linux Enterprise High Performance Computing 12 SP5 python3-base Released
SUSE Linux Enterprise High Performance Computing 12 SP5 python36 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 python-future Released
SUSE Linux Enterprise High Performance Computing 15 SP5 python3 Not affected
SUSE Linux Enterprise Micro 5.1 python-future Released
SUSE Linux Enterprise Micro 5.1 python3 Not affected
SUSE Linux Enterprise Micro 5.2 python-future Released
SUSE Linux Enterprise Micro 5.2 python3 Not affected
SUSE Linux Enterprise Micro 5.3 python-future Released
SUSE Linux Enterprise Micro 5.3 python3 Not affected
SUSE Linux Enterprise Micro 5.4 python-future Released
SUSE Linux Enterprise Micro 5.4 python3 Not affected
SUSE Linux Enterprise Micro 5.5 python-future Affected
SUSE Linux Enterprise Micro 5.5 python3 Not affected
SUSE Linux Enterprise Micro for Rancher 5.2 python-future Released
SUSE Linux Enterprise Micro for Rancher 5.3 python-future Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 python-future Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 python3 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP5 python3 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 python Not affected
SUSE Linux Enterprise Module for Public Cloud 12 python-future Released
SUSE Linux Enterprise Module for Web and Scripting 12 python3 Released
SUSE Linux Enterprise Module for Web and Scripting 12 python3-base Released
SUSE Linux Enterprise Real Time 15 SP3 python Not affected
SUSE Linux Enterprise Real Time 15 SP3 python-future Released
SUSE Linux Enterprise Real Time 15 SP3 python3 Not affected
SUSE Linux Enterprise Real Time 15 SP3 python39 Not affected
SUSE Linux Enterprise Server 12 SP5 python Not affected
SUSE Linux Enterprise Server 12 SP5 python-future Released
SUSE Linux Enterprise Server 12 SP5 python3 Released
SUSE Linux Enterprise Server 12 SP5 python3-base Released
SUSE Linux Enterprise Server 12 SP5 python36 Not affected
SUSE Linux Enterprise Server 12-LTSS python3 Affected
SUSE Linux Enterprise Server 12-LTSS python3-base Affected
SUSE Linux Enterprise Server 15 SP5 python-future Released
SUSE Linux Enterprise Server 15 SP5 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python-future Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python3-base Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 python36 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python-future Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python310 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 python-future Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 python3 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 python3 Released
SUSE Linux Enterprise Software Development Kit 12 SP5 python3-base Released
SUSE Linux Enterprise Software Development Kit 12 SP5 python36 Not affected
SUSE Manager Proxy 4.3 python-future Released
SUSE Manager Proxy 4.3 python3 Not affected
SUSE Manager Proxy 4.3 python310 Not affected
SUSE Manager Retail Branch Server 4.3 python-future Released
SUSE Manager Retail Branch Server 4.3 python3 Not affected
SUSE Manager Retail Branch Server 4.3 python310 Not affected
SUSE Manager Server 4.3 python-future Released
SUSE Manager Server 4.3 python3 Not affected
SUSE Manager Server 4.3 python310 Not affected
openSUSE Leap Micro 5.3 python-future Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS python3 Not affected
SLES15-SP1-CHOST-BYOS-Azure python3 Not affected
SLES15-SP1-CHOST-BYOS-EC2 python3 Not affected
SLES15-SP1-CHOST-BYOS-GCE python3 Not affected
SLES15-SP2-CHOST-BYOS-Aliyun python3 Not affected
SLES15-SP2-CHOST-BYOS-Azure python3 Not affected
SLES15-SP2-CHOST-BYOS-EC2 python3 Not affected
SLES15-SP2-CHOST-BYOS-GCE python3 Not affected
SLES15-SP3-CHOST-BYOS-Aliyun python3 Not affected
SLES15-SP3-CHOST-BYOS-Azure python3 Not affected
SLES15-SP3-CHOST-BYOS-EC2 python3 Not affected
SLES15-SP3-CHOST-BYOS-GCE python3 Not affected
SLES15-SP3-CHOST-BYOS-SAP-CCloud python3 Not affected
SLES15-SP4-CHOST-BYOS python3 Not affected
SLES15-SP4-CHOST-BYOS-Aliyun python3 Not affected
SLES15-SP4-CHOST-BYOS-Azure python3 Not affected
SLES15-SP4-CHOST-BYOS-EC2 python3 Not affected
SLES15-SP4-CHOST-BYOS-GCE python3 Not affected
SLES15-SP4-CHOST-BYOS-SAP-CCloud python3 Not affected
SUSE Linux Enterprise Desktop 15 SP4 python-future Released
SUSE Linux Enterprise Desktop 15 SP4 python3 Not affected
SUSE Linux Enterprise Desktop 15 SP4 python310 Not affected
SUSE Linux Enterprise High Performance Computing 15 python Not affected
SUSE Linux Enterprise High Performance Computing 15 python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 python39 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python-future Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python39 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python-future Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python39 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 python-future Released
SUSE Linux Enterprise High Performance Computing 15 SP4 python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 python310 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS python-future Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS python310 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS python-future Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS python310 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS python Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15-ESPOS python3 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS python Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS python-future Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-future Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-future Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP3 python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python39 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 python-future Released
SUSE Linux Enterprise Module for Basesystem 15 SP4 python3 Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 python Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 python Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 python3 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 python39 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 python3 Not affected
SUSE Linux Enterprise Module for Python 2 15 SP2 python Not affected
SUSE Linux Enterprise Module for Python 2 15 SP2 python-future Unsupported
SUSE Linux Enterprise Module for Python 2 15 SP3 python Not affected
SUSE Linux Enterprise Module for Python 2 15 SP3 python-future Unsupported
SUSE Linux Enterprise Module for Python 3 15 SP4 python310 Not affected
SUSE Linux Enterprise Server 15 SP2 python Not affected
SUSE Linux Enterprise Server 15 SP2 python-future Unsupported
SUSE Linux Enterprise Server 15 SP2 python3 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS python Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS python-future Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS python3 Not affected
SUSE Linux Enterprise Server 15 SP3 python Not affected
SUSE Linux Enterprise Server 15 SP3 python-future Unsupported
SUSE Linux Enterprise Server 15 SP3 python3 Not affected
SUSE Linux Enterprise Server 15 SP3 python39 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS python Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS python-future Affected
SUSE Linux Enterprise Server 15 SP3-LTSS python3 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS python39 Not affected
SUSE Linux Enterprise Server 15 SP4 python-future Released
SUSE Linux Enterprise Server 15 SP4 python3 Not affected
SUSE Linux Enterprise Server 15 SP4 python310 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS python-future Affected
SUSE Linux Enterprise Server 15 SP4-LTSS python3 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS python310 Not affected
SUSE Linux Enterprise Server 15-ESPOS python Not affected
SUSE Linux Enterprise Server 15-ESPOS python-future Unsupported
SUSE Linux Enterprise Server 15-ESPOS python3 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-future Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python3 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python-future Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python3 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 python Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 python-future Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 python3 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 python39 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 python Not affected
SUSE Linux Enterprise Server for SAP Applications 15 python-future Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-future Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python-future Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python-future Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python3 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python39 Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 python Not affected
HPE Helion OpenStack 8 python-future Affected
HPE Helion OpenStack 8 python3 Affected
HPE Helion OpenStack 8 python3-base Affected
SUSE CaaS Platform 3.0 python Not affected
SUSE CaaS Platform 4.0 python Not affected
SUSE CaaS Platform 4.0 python-future Unsupported
SUSE CaaS Platform 4.0 python3 Not affected
SUSE Enterprise Storage 5 python Not affected
SUSE Enterprise Storage 6 python Not affected
SUSE Enterprise Storage 6 python-future Affected
SUSE Enterprise Storage 6 python3 Not affected
SUSE Enterprise Storage 7 python Not affected
SUSE Enterprise Storage 7 python-future Affected
SUSE Enterprise Storage 7 python3 Not affected
SUSE Linux Enterprise Desktop 11 SP4 python Affected
SUSE Linux Enterprise Desktop 11 SP4 python-base Affected
SUSE Linux Enterprise Desktop 11 SP4 python-doc Affected
SUSE Linux Enterprise Desktop 12 python3 Affected
SUSE Linux Enterprise Desktop 12 python3-base Affected
SUSE Linux Enterprise Desktop 12 SP1 python Not affected
SUSE Linux Enterprise Desktop 12 SP1 python3 Affected
SUSE Linux Enterprise Desktop 12 SP1 python3-base Affected
SUSE Linux Enterprise Desktop 12 SP2 python Not affected
SUSE Linux Enterprise Desktop 12 SP2 python3 Affected
SUSE Linux Enterprise Desktop 12 SP2 python3-base Affected
SUSE Linux Enterprise Desktop 12 SP3 python Not affected
SUSE Linux Enterprise Desktop 12 SP3 python3 Affected
SUSE Linux Enterprise Desktop 12 SP3 python3-base Affected
SUSE Linux Enterprise Desktop 12 SP4 python Not affected
SUSE Linux Enterprise Desktop 12 SP4 python3 Affected
SUSE Linux Enterprise Desktop 12 SP4 python3-base Affected
SUSE Linux Enterprise Desktop 15 python Not affected
SUSE Linux Enterprise Desktop 15 python-future Unsupported
SUSE Linux Enterprise Desktop 15 python3 Not affected
SUSE Linux Enterprise Desktop 15 SP1 python Not affected
SUSE Linux Enterprise Desktop 15 SP1 python-future Unsupported
SUSE Linux Enterprise Desktop 15 SP1 python3 Not affected
SUSE Linux Enterprise Desktop 15 SP2 python Not affected
SUSE Linux Enterprise Desktop 15 SP2 python-future Unsupported
SUSE Linux Enterprise Desktop 15 SP2 python3 Not affected
SUSE Linux Enterprise Desktop 15 SP3 python Not affected
SUSE Linux Enterprise Desktop 15 SP3 python-future Unsupported
SUSE Linux Enterprise Desktop 15 SP3 python3 Not affected
SUSE Linux Enterprise Desktop 15 SP3 python39 Not affected
SUSE Linux Enterprise Micro 5.0 python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 python Not affected
SUSE Linux Enterprise Module for Basesystem 15 python-future Unsupported
SUSE Linux Enterprise Module for Basesystem 15 python3 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-future Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP1 python3 Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 python Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 python Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 python Not affected
SUSE Linux Enterprise Module for Python 2 15 SP1 python Not affected
SUSE Linux Enterprise Module for Python 2 15 SP1 python-future Unsupported
SUSE Linux Enterprise Real Time 15 SP2 python Not affected
SUSE Linux Enterprise Real Time 15 SP2 python-future Unsupported
SUSE Linux Enterprise Real Time 15 SP2 python3 Not affected
SUSE Linux Enterprise Real Time 15 SP4 python-future Affected
SUSE Linux Enterprise Real Time 15 SP4 python3 Not affected
SUSE Linux Enterprise Server 11 SP3 python Affected
SUSE Linux Enterprise Server 11 SP3 python-base Affected
SUSE Linux Enterprise Server 11 SP3 python-doc Affected
SUSE Linux Enterprise Server 11 SP3-LTSS python Affected
SUSE Linux Enterprise Server 11 SP3-LTSS python-base Affected
SUSE Linux Enterprise Server 11 SP3-LTSS python-doc Affected
SUSE Linux Enterprise Server 11 SP4 python Affected
SUSE Linux Enterprise Server 11 SP4 python-base Affected
SUSE Linux Enterprise Server 11 SP4 python-doc Affected
SUSE Linux Enterprise Server 11 SP4-LTSS python Affected
SUSE Linux Enterprise Server 11 SP4-LTSS python-base Affected
SUSE Linux Enterprise Server 11 SP4-LTSS python-doc Affected
SUSE Linux Enterprise Server 12 python-future Released
SUSE Linux Enterprise Server 12 python3 Released
SUSE Linux Enterprise Server 12 python3-base Released
SUSE Linux Enterprise Server 12 SP1 python Not affected
SUSE Linux Enterprise Server 12 SP1 python3 Affected
SUSE Linux Enterprise Server 12 SP1 python3-base Affected
SUSE Linux Enterprise Server 12 SP1-LTSS python Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS python3 Affected
SUSE Linux Enterprise Server 12 SP1-LTSS python3-base Affected
SUSE Linux Enterprise Server 12 SP2 python Not affected
SUSE Linux Enterprise Server 12 SP2 python3 Affected
SUSE Linux Enterprise Server 12 SP2 python3-base Affected
SUSE Linux Enterprise Server 12 SP2-BCL python Not affected
SUSE Linux Enterprise Server 12 SP2-BCL python3 Released
SUSE Linux Enterprise Server 12 SP2-BCL python3-base Released
SUSE Linux Enterprise Server 12 SP2-ESPOS python Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS python3 Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS python3-base Affected
SUSE Linux Enterprise Server 12 SP2-LTSS python Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS python3 Affected
SUSE Linux Enterprise Server 12 SP2-LTSS python3-base Affected
SUSE Linux Enterprise Server 12 SP3 python Not affected
SUSE Linux Enterprise Server 12 SP3 python-future Released
SUSE Linux Enterprise Server 12 SP3 python3 Released
SUSE Linux Enterprise Server 12 SP3 python3-base Released
SUSE Linux Enterprise Server 12 SP3-BCL python Not affected
SUSE Linux Enterprise Server 12 SP3-BCL python-future Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL python3 Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL python3-base Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS python Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS python-future Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS python3 Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS python3-base Affected
SUSE Linux Enterprise Server 12 SP3-LTSS python Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS python-future Affected
SUSE Linux Enterprise Server 12 SP3-LTSS python3 Affected
SUSE Linux Enterprise Server 12 SP3-LTSS python3-base Affected
SUSE Linux Enterprise Server 12 SP4 python Not affected
SUSE Linux Enterprise Server 12 SP4 python-future Released
SUSE Linux Enterprise Server 12 SP4 python3 Released
SUSE Linux Enterprise Server 12 SP4 python3-base Released
SUSE Linux Enterprise Server 12 SP4-ESPOS python Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS python-future Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS python3 Released
SUSE Linux Enterprise Server 12 SP4-ESPOS python3-base Released
SUSE Linux Enterprise Server 12 SP4-LTSS python Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS python-future Affected
SUSE Linux Enterprise Server 12 SP4-LTSS python3 Released
SUSE Linux Enterprise Server 12 SP4-LTSS python3-base Released
SUSE Linux Enterprise Server 15 python Not affected
SUSE Linux Enterprise Server 15 python-future Unsupported
SUSE Linux Enterprise Server 15 python3 Not affected
SUSE Linux Enterprise Server 15 SP1 python Not affected
SUSE Linux Enterprise Server 15 SP1 python-future Unsupported
SUSE Linux Enterprise Server 15 SP1 python3 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL python Not affected
SUSE Linux Enterprise Server 15 SP1-BCL python-future Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL python3 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS python Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS python-future Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS python3 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL python Not affected
SUSE Linux Enterprise Server 15 SP2-BCL python-future Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL python3 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL python Not affected
SUSE Linux Enterprise Server 15 SP3-BCL python-future Affected
SUSE Linux Enterprise Server 15 SP3-BCL python3 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL python39 Not affected
SUSE Linux Enterprise Server 15-LTSS python Not affected
SUSE Linux Enterprise Server 15-LTSS python-future Unsupported
SUSE Linux Enterprise Server 15-LTSS python3 Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 python Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 python3 Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 python3-base Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 python Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 python-base Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 python-doc Affected
SUSE Linux Enterprise Server for SAP Applications 12 python-future Released
SUSE Linux Enterprise Server for SAP Applications 12 python3 Released
SUSE Linux Enterprise Server for SAP Applications 12 python3-base Released
SUSE Linux Enterprise Server for SAP Applications 12 SP1 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 python3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 python3-base Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 python3-base Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python-future Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 python3-base Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python-future Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 python3-base Released
SUSE Linux Enterprise Software Development Kit 11 SP4 python Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 python-base Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 python-doc Affected
SUSE Linux Enterprise Software Development Kit 12 python3-base Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 python3-base Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 python3-base Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 python3-base Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 python3 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 python3-base Affected
SUSE Manager Proxy 4.0 python Not affected
SUSE Manager Proxy 4.0 python-future Unsupported
SUSE Manager Proxy 4.0 python3 Not affected
SUSE Manager Proxy 4.1 python Not affected
SUSE Manager Proxy 4.1 python-future Unsupported
SUSE Manager Proxy 4.1 python3 Not affected
SUSE Manager Proxy 4.2 python Not affected
SUSE Manager Proxy 4.2 python-future Unsupported
SUSE Manager Proxy 4.2 python3 Not affected
SUSE Manager Proxy 4.2 python39 Not affected
SUSE Manager Retail Branch Server 4.0 python Not affected
SUSE Manager Retail Branch Server 4.0 python-future Unsupported
SUSE Manager Retail Branch Server 4.0 python3 Not affected
SUSE Manager Retail Branch Server 4.1 python Not affected
SUSE Manager Retail Branch Server 4.1 python-future Unsupported
SUSE Manager Retail Branch Server 4.1 python3 Not affected
SUSE Manager Retail Branch Server 4.2 python Not affected
SUSE Manager Retail Branch Server 4.2 python-future Unsupported
SUSE Manager Retail Branch Server 4.2 python3 Not affected
SUSE Manager Retail Branch Server 4.2 python39 Not affected
SUSE Manager Server 4.0 python Not affected
SUSE Manager Server 4.0 python-future Unsupported
SUSE Manager Server 4.0 python3 Not affected
SUSE Manager Server 4.1 python Not affected
SUSE Manager Server 4.1 python-future Unsupported
SUSE Manager Server 4.1 python3 Not affected
SUSE Manager Server 4.2 python Not affected
SUSE Manager Server 4.2 python-future Unsupported
SUSE Manager Server 4.2 python3 Not affected
SUSE Manager Server 4.2 python39 Not affected
SUSE OpenStack Cloud 7 python Not affected
SUSE OpenStack Cloud 7 python3 Affected
SUSE OpenStack Cloud 7 python3-base Affected
SUSE OpenStack Cloud 8 python Not affected
SUSE OpenStack Cloud 8 python-future Affected
SUSE OpenStack Cloud 8 python3 Affected
SUSE OpenStack Cloud 8 python3-base Affected
SUSE OpenStack Cloud 9 python Not affected
SUSE OpenStack Cloud 9 python-future Affected
SUSE OpenStack Cloud 9 python3 Released
SUSE OpenStack Cloud 9 python3-base Released
SUSE OpenStack Cloud Crowbar 8 python Not affected
SUSE OpenStack Cloud Crowbar 8 python-future Affected
SUSE OpenStack Cloud Crowbar 8 python3 Affected
SUSE OpenStack Cloud Crowbar 8 python3-base Affected
SUSE OpenStack Cloud Crowbar 9 python Not affected
SUSE OpenStack Cloud Crowbar 9 python-future Affected
SUSE OpenStack Cloud Crowbar 9 python3 Released
SUSE OpenStack Cloud Crowbar 9 python3-base Released
openSUSE Leap 15.3 python-future Released
openSUSE Leap 15.4 python-future Released
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise packages for Open Build Service 12 SP3 python-future Affected
Container Status
bci/python:3 python310Not affected
bci/python:3 python39Not affected
bci/python:3
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7.1/cephcsi/cephcsi
ses/7.1/rook/ceph
ses/7/ceph/ceph
ses/7/cephcsi/cephcsi
ses/7/rook/ceph
suse/389-ds
suse/manager/4.3/proxy-httpd
suse/manager/4.3/proxy-salt-broker
suse/manager/4.3/proxy-ssh
suse/manager/4.3/proxy-tftpd
suse/manager/5.0/x86_64/proxy-httpd
suse/manager/5.0/x86_64/proxy-salt-broker
suse/manager/5.0/x86_64/proxy-ssh
suse/manager/5.0/x86_64/proxy-tftpd
suse/manager/5.0/x86_64/server
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/virt-launcher:0.49.0
trento/trento-runner
python3Not affected


SUSE Timeline for this CVE

CVE page created: Fri Dec 23 05:00:03 2022
CVE page last modified: Fri Apr 12 12:04:19 2024