Upstream information

CVE-2022-28321 at MITRE

Description

The Linux-PAM package before 1.5.2-6.1 for openSUSE Tumbleweed allows authentication bypass for SSH logins. The pam_access.so module doesn't correctly restrict login if a user tries to connect from an IP address that is not resolvable via DNS. In such conditions, a user with denied access to a machine can still get access. NOTE: the relevance of this issue is largely limited to openSUSE Tumbleweed and openSUSE Factory; it does not affect Linux-PAM upstream.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1197654 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SLES15-SP5-CHOST-BYOS-Aliyun pam Already fixed
SLES15-SP5-CHOST-BYOS-Azure pam Already fixed
SLES15-SP5-CHOST-BYOS-EC2 pam Already fixed
SLES15-SP5-CHOST-BYOS-GCE pam Already fixed
SLES15-SP5-CHOST-BYOS-SAP-CCloud pam Already fixed
SUSE Enterprise Storage 7.1 pam Already fixed
SUSE Linux Enterprise Desktop 15 SP5 pam Already fixed
SUSE Linux Enterprise Desktop 15 SP6 pam Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 pam Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 pam Already fixed
SUSE Linux Enterprise Micro 5.1 pam Already fixed
SUSE Linux Enterprise Micro 5.2 pam Already fixed
SUSE Linux Enterprise Micro 5.3 pam Already fixed
SUSE Linux Enterprise Micro 5.4 pam Already fixed
SUSE Linux Enterprise Micro 5.5 pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP6 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP5 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP6 pam Already fixed
SUSE Linux Enterprise Server 12 SP5 pam Not affected
SUSE Linux Enterprise Server 15 SP5 pam Already fixed
SUSE Linux Enterprise Server 15 SP6 pam Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 pam Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 pam Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 pam Not affected
SUSE Manager Proxy 4.3 pam Already fixed
SUSE Manager Retail Branch Server 4.3 pam Already fixed
SUSE Manager Server 4.3 pam Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS pam Already fixed
SLES15-SP1-CHOST-BYOS-Azure pam Already fixed
SLES15-SP1-CHOST-BYOS-EC2 pam Already fixed
SLES15-SP1-CHOST-BYOS-GCE pam Already fixed
SLES15-SP2-CHOST-BYOS-Aliyun pam Already fixed
SLES15-SP2-CHOST-BYOS-Azure pam Already fixed
SLES15-SP2-CHOST-BYOS-EC2 pam Already fixed
SLES15-SP2-CHOST-BYOS-GCE pam Already fixed
SLES15-SP3-CHOST-BYOS-Aliyun pam Already fixed
SLES15-SP3-CHOST-BYOS-Azure pam Already fixed
SLES15-SP3-CHOST-BYOS-EC2 pam Already fixed
SLES15-SP3-CHOST-BYOS-GCE pam Already fixed
SLES15-SP3-CHOST-BYOS-SAP-CCloud pam Already fixed
SLES15-SP4-CHOST-BYOS pam Already fixed
SLES15-SP4-CHOST-BYOS-Aliyun pam Already fixed
SLES15-SP4-CHOST-BYOS-Azure pam Already fixed
SLES15-SP4-CHOST-BYOS-EC2 pam Already fixed
SLES15-SP4-CHOST-BYOS-GCE pam Already fixed
SLES15-SP4-CHOST-BYOS-SAP-CCloud pam Already fixed
SUSE Linux Enterprise Desktop 15 SP4 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP2 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP3 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 pam Already fixed
SUSE Linux Enterprise Server 15 SP2 pam Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS pam Already fixed
SUSE Linux Enterprise Server 15 SP3 pam Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS pam Already fixed
SUSE Linux Enterprise Server 15 SP4 pam Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS pam Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 pam Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 pam Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 pam Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 pam Not affected
SUSE CaaS Platform 3.0 pam Not affected
SUSE CaaS Platform 4.0 pam Already fixed
SUSE Enterprise Storage 6 pam Already fixed
SUSE Enterprise Storage 7 pam Already fixed
SUSE Linux Enterprise Desktop 12 pam Not affected
SUSE Linux Enterprise Desktop 12 SP1 pam Not affected
SUSE Linux Enterprise Desktop 12 SP2 pam Not affected
SUSE Linux Enterprise Desktop 12 SP3 pam Not affected
SUSE Linux Enterprise Desktop 12 SP4 pam Not affected
SUSE Linux Enterprise Desktop 15 pam Already fixed
SUSE Linux Enterprise Desktop 15 SP1 pam Already fixed
SUSE Linux Enterprise Desktop 15 SP2 pam Already fixed
SUSE Linux Enterprise Desktop 15 SP3 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS pam Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS pam Already fixed
SUSE Linux Enterprise Micro 5.0 pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 pam Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 pam Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP1 pam Already fixed
SUSE Linux Enterprise Real Time 15 SP2 pam Already fixed
SUSE Linux Enterprise Real Time 15 SP3 pam Already fixed
SUSE Linux Enterprise Real Time 15 SP4 pam Already fixed
SUSE Linux Enterprise Server 11 SP3 pam Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS pam Not affected
SUSE Linux Enterprise Server 12 pam Not affected
SUSE Linux Enterprise Server 12 SP1 pam Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS pam Not affected
SUSE Linux Enterprise Server 12 SP2 pam Not affected
SUSE Linux Enterprise Server 12 SP2-BCL pam Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS pam Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS pam Not affected
SUSE Linux Enterprise Server 12 SP3 pam Not affected
SUSE Linux Enterprise Server 12 SP3-BCL pam Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS pam Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS pam Not affected
SUSE Linux Enterprise Server 12 SP4 pam Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS pam Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS pam Not affected
SUSE Linux Enterprise Server 12-LTSS pam Not affected
SUSE Linux Enterprise Server 15 pam Already fixed
SUSE Linux Enterprise Server 15 SP1 pam Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL pam Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS pam Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL pam Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL pam Already fixed
SUSE Linux Enterprise Server 15-LTSS pam Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 pam Not affected
SUSE Linux Enterprise Server for SAP Applications 15 pam Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 pam Already fixed
SUSE Linux Enterprise Software Development Kit 12 pam Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 pam Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 pam Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 pam Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 pam Not affected
SUSE Manager Proxy 4.0 pam Already fixed
SUSE Manager Proxy 4.1 pam Already fixed
SUSE Manager Proxy 4.2 pam Already fixed
SUSE Manager Retail Branch Server 4.0 pam Already fixed
SUSE Manager Retail Branch Server 4.1 pam Already fixed
SUSE Manager Retail Branch Server 4.2 pam Already fixed
SUSE Manager Server 4.0 pam Already fixed
SUSE Manager Server 4.1 pam Already fixed
SUSE Manager Server 4.2 pam Already fixed
SUSE OpenStack Cloud 7 pam Not affected
SUSE OpenStack Cloud 8 pam Not affected
SUSE OpenStack Cloud 9 pam Not affected
SUSE OpenStack Cloud Crowbar 8 pam Not affected
SUSE OpenStack Cloud Crowbar 9 pam Not affected
Container Status
bci/bci-init
bci/bci-init:15.3
bci/bci-init:15.4
bci/bci-init:15.6
bci/bci-sle15-kernel-module-devel
bci/bci-sle15-kernel-module-devel:15.6
bci/dotnet-aspnet
bci/dotnet-aspnet:3.1
bci/dotnet-aspnet:5.0
bci/dotnet-aspnet:6.0
bci/dotnet-runtime
bci/dotnet-runtime:3.1
bci/dotnet-runtime:5.0
bci/dotnet-runtime:6.0
bci/dotnet-sdk
bci/dotnet-sdk:3.1
bci/dotnet-sdk:5.0
bci/dotnet-sdk:6.0
bci/golang
bci/golang:1.16
bci/golang:1.17
bci/golang:1.18
bci/golang:1.19
bci/node:12
bci/node:14
bci/node:16
bci/node:18
bci/nodejs
bci/openjdk
bci/openjdk-devel
bci/openjdk-devel:11
bci/openjdk-devel:21
bci/openjdk:11
bci/php
bci/php-apache
bci/php-apache:8
bci/php-fpm
bci/php-fpm:8
bci/php:8
bci/python
bci/python:3
bci/ruby
bci/rust
bci/rust:1.56
bci/rust:1.59
bci/rust:1.60
bci/rust:1.61
bci/rust:1.62
bci/rust:1.63
bci/rust:1.64
bci/rust:1.65
bci/rust:1.66
bci/rust:1.67
bci/rust:1.68
rancher/elemental-builder-image/5.3
rancher/elemental-operator
rancher/elemental-operator/5.3
rancher/elemental-teal-iso/5.3
rancher/elemental-teal-iso/5.4
rancher/elemental-teal-rt/5.3
rancher/elemental-teal-rt/5.4
rancher/elemental-teal/5.3
rancher/elemental-teal/5.4
rancher/seedimage-builder
rancher/seedimage-builder/5.3
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7.1/ceph/grafana
ses/7.1/ceph/haproxy
ses/7.1/ceph/keepalived
ses/7.1/ceph/prometheus-alertmanager
ses/7.1/ceph/prometheus-node-exporter
ses/7.1/ceph/prometheus-server
ses/7.1/ceph/prometheus-snmp_notifier
ses/7.1/cephcsi/cephcsi
ses/7.1/cephcsi/csi-attacher:v4.1.0
ses/7.1/cephcsi/csi-node-driver-registrar:v2.7.0
ses/7.1/cephcsi/csi-provisioner:v3.4.0
ses/7.1/cephcsi/csi-resizer:v1.7.0
ses/7.1/cephcsi/csi-snapshotter:v6.2.1
ses/7.1/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/389-ds
suse/hpc/warewulf4-x86_64/sle-hpc-node
suse/ltss/sle15.3/sle15:15.3
suse/ltss/sle15.4/sle15:15.4
suse/manager/4.3/proxy-httpd
suse/manager/4.3/proxy-salt-broker
suse/manager/4.3/proxy-squid
suse/manager/4.3/proxy-ssh
suse/manager/5.0/x86_64/proxy-httpd
suse/manager/5.0/x86_64/proxy-salt-broker
suse/manager/5.0/x86_64/proxy-squid
suse/manager/5.0/x86_64/proxy-ssh
suse/manager/5.0/x86_64/server
suse/manager/5.0/x86_64/server-hub-xmlrpc-api
suse/manager/5.0/x86_64/server-migration-14-16
suse/nginx
suse/pcp
suse/pcp:5
suse/postgres
suse/postgres:10
suse/postgres:12
suse/postgres:13
suse/postgres:14
suse/postgres:15
suse/registry
suse/rmt-mariadb
suse/rmt-mariadb-client
suse/rmt-nginx
suse/rmt-server
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle-micro-rancher/5.4
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sle-micro/5.4/toolbox
suse/sle-micro/5.5
suse/sle-micro/5.5/toolbox
suse/sle-micro/base-5.5
suse/sle-micro/kvm-5.5
suse/sle-micro/rt-5.5
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
suse/sle15:15.3
suse/sle15:15.4
suse/sle15:15.5
suse/sle15:15.6
suse/sles/15.2/virt-api:0.38.1
suse/sles/15.2/virt-controller:0.38.1
suse/sles/15.2/virt-handler:0.38.1
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.2/virt-operator:0.38.1
suse/sles/15.3/cdi-apiserver:1.37.1
suse/sles/15.3/cdi-cloner:1.37.1
suse/sles/15.3/cdi-controller:1.37.1
suse/sles/15.3/cdi-importer:1.37.1
suse/sles/15.3/cdi-operator:1.37.1
suse/sles/15.3/cdi-uploadproxy:1.37.1
suse/sles/15.3/cdi-uploadserver:1.37.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-api:0.45.0
suse/sles/15.3/virt-controller:0.45.0
suse/sles/15.3/virt-handler:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.3/virt-operator:0.45.0
suse/sles/15.4/cdi-apiserver:1.43.0
suse/sles/15.4/cdi-cloner:1.43.0
suse/sles/15.4/cdi-controller:1.43.0
suse/sles/15.4/cdi-importer:1.43.0
suse/sles/15.4/cdi-operator:1.43.0
suse/sles/15.4/cdi-uploadproxy:1.43.0
suse/sles/15.4/cdi-uploadserver:1.43.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-api:0.49.0
suse/sles/15.4/virt-controller:0.49.0
suse/sles/15.4/virt-handler:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
suse/sles/15.4/virt-operator:0.49.0
suse/sles/15.5/cdi-apiserver:1.55.0
suse/sles/15.5/cdi-cloner:1.55.0
suse/sles/15.5/cdi-controller:1.55.0
suse/sles/15.5/cdi-importer:1.55.0
suse/sles/15.5/cdi-operator:1.55.0
suse/sles/15.5/cdi-uploadproxy:1.55.0
suse/sles/15.5/cdi-uploadserver:1.55.0
suse/sles/15.5/libguestfs-tools:0.58.0
suse/sles/15.5/virt-api:0.58.0
suse/sles/15.5/virt-controller:0.58.0
suse/sles/15.5/virt-exportproxy:0.58.0
suse/sles/15.5/virt-exportserver:0.58.0
suse/sles/15.5/virt-handler:0.58.0
suse/sles/15.5/virt-launcher:0.58.0
suse/sles/15.5/virt-operator:0.58.0
suse/sles/15.6/cdi-apiserver:1.58.0
suse/sles/15.6/cdi-cloner:1.58.0
suse/sles/15.6/cdi-controller:1.58.0
suse/sles/15.6/cdi-importer:1.58.0
suse/sles/15.6/cdi-operator:1.58.0
suse/sles/15.6/cdi-uploadproxy:1.58.0
suse/sles/15.6/cdi-uploadserver:1.58.0
suse/sles/15.6/libguestfs-tools:1.1.1
suse/sles/15.6/pr-helper:1.1.1
suse/sles/15.6/virt-api:1.1.1
suse/sles/15.6/virt-controller:1.1.1
suse/sles/15.6/virt-exportproxy:1.1.1
suse/sles/15.6/virt-exportserver:1.1.1
suse/sles/15.6/virt-handler:1.1.1
suse/sles/15.6/virt-launcher:1.1.1
suse/sles/15.6/virt-operator:1.1.1
trento/trento-db
trento/trento-runner
trento/trento-wanda
trento/trento-web
pamAlready fixed
suse/sles12sp3
suse/sles12sp4
suse/sles12sp5
pamNot affected


SUSE Timeline for this CVE

CVE page created: Fri May 13 08:15:06 2022
CVE page last modified: Thu Jun 6 00:44:05 2024