Upstream information

CVE-2022-28327 at MITRE

Description

The generic P-256 feature in crypto/elliptic in Go before 1.17.9 and 1.18.x before 1.18.1 allows a panic via long scalar input.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.9
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1

Note from the SUSE Security Team on the go1.* package

SUSE only supports the current and the previous GO language releases.

SUSE Bugzilla entry: 1198424 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/golang:1.17-12.3
  • go1.17 >= 1.17.9-150000.1.28.1
Container bci/golang:1.18
Container bci/golang:1.18-7.3
  • go1.18 >= 1.18.1-150000.1.11.1
SUSE Enterprise Storage 7.1
  • go1.17 >= 1.17.9-150000.1.28.1
  • go1.17-doc >= 1.17.9-150000.1.28.1
  • go1.17-race >= 1.17.9-150000.1.28.1
  • go1.18 >= 1.18.1-150000.1.11.1
  • go1.18-doc >= 1.18.1-150000.1.11.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.1-150000.1.11.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1410
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1411
SUSE-Storage-7.1-2023-2312
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Development Tools 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • go1.17 >= 1.17.9-150000.1.28.1
  • go1.17-doc >= 1.17.9-150000.1.28.1
  • go1.17-race >= 1.17.9-150000.1.28.1
  • go1.18 >= 1.18.1-150000.1.11.1
  • go1.18-doc >= 1.18.1-150000.1.11.1
  • go1.18-race >= 1.18.1-150000.1.11.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1410
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1411
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Development Tools 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • go1.17 >= 1.17.9-150000.1.31.1
  • go1.17-doc >= 1.17.9-150000.1.31.1
  • go1.17-race >= 1.17.9-150000.1.31.1
  • go1.18 >= 1.18.1-150000.1.14.1
  • go1.18-doc >= 1.18.1-150000.1.14.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.1-150000.1.14.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA go1.17-1.17.9-150000.1.31.1
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA go1.18-1.18.1-150000.1.14.1
SUSE-SLE-Module-Development-Tools-15-SP4-2023-2312
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-2312
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-2312
SUSE Linux Enterprise Real Time 15 SP2
  • go1.17 >= 1.17.9-150000.1.28.1
  • go1.17-doc >= 1.17.9-150000.1.28.1
  • go1.17-race >= 1.17.9-150000.1.28.1
Patchnames:
SUSE-SLE-Product-RT-15-SP2-2022-1411
SUSE Linux Enterprise Real Time 15 SP3
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-RT-15-SP3-2023-2312
SUSE Linux Enterprise Server 15 SP3-LTSS
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-2312
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • go1.17 >= 1.17.9-150000.1.28.1
  • go1.17-doc >= 1.17.9-150000.1.28.1
  • go1.17-race >= 1.17.9-150000.1.28.1
  • go1.18 >= 1.18.1-150000.1.11.1
  • go1.18-doc >= 1.18.1-150000.1.11.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.1-150000.1.11.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1410
SUSE-SLE-Module-Development-Tools-15-SP3-2022-1411
SUSE-SLE-Product-SLES_SAP-15-SP3-2023-2312
openSUSE Leap 15.3
  • go1.17 >= 1.17.9-150000.1.28.1
  • go1.17-doc >= 1.17.9-150000.1.28.1
  • go1.17-race >= 1.17.9-150000.1.28.1
  • go1.18 >= 1.18.1-150000.1.11.1
  • go1.18-doc >= 1.18.1-150000.1.11.1
  • go1.18-race >= 1.18.1-150000.1.11.1
Patchnames:
openSUSE-SLE-15.3-2022-1410
openSUSE-SLE-15.3-2022-1411
openSUSE Leap 15.4
  • go1.17 >= 1.17.9-150000.1.28.1
  • go1.17-doc >= 1.17.9-150000.1.28.1
  • go1.17-race >= 1.17.9-150000.1.28.1
  • go1.18 >= 1.18.1-150000.1.11.1
  • go1.18-doc >= 1.18.1-150000.1.11.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.1-150000.1.11.1
Patchnames:
openSUSE-SLE-15.4-2022-1410
openSUSE-SLE-15.4-2022-1411
openSUSE-SLE-15.4-2023-2312
openSUSE Leap 15.5
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
openSUSE-SLE-15.5-2023-2312
openSUSE Tumbleweed
  • go1.17 >= 1.17.9-1.1
  • go1.17-doc >= 1.17.9-1.1
  • go1.17-race >= 1.17.9-1.1
  • go1.18 >= 1.18.1-1.1
  • go1.18-doc >= 1.18.1-1.1
  • go1.18-race >= 1.18.1-1.1
Patchnames:
openSUSE Tumbleweed GA go1.17-1.17.9-1.1
openSUSE Tumbleweed GA go1.18-1.18.1-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 go1.15 Not affected
SUSE Enterprise Storage 7 go1.16 Not affected
SUSE Enterprise Storage 7 go1.17 Affected
SUSE Enterprise Storage 7.1 go1.15 Not affected
SUSE Enterprise Storage 7.1 go1.16 Not affected
SUSE Enterprise Storage 7.1 go1.17 Released
SUSE Enterprise Storage 7.1 go1.18 Released
SUSE Enterprise Storage 7.1 go1.18-openssl Released
SUSE Linux Enterprise Desktop 15 SP4 go1.17 Released
SUSE Linux Enterprise Desktop 15 SP4 go1.18 Already fixed
SUSE Linux Enterprise Desktop 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.17 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.18 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.17 Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.18 Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Real Time 15 SP3 go1.15 Not affected
SUSE Linux Enterprise Real Time 15 SP3 go1.16 Not affected
SUSE Linux Enterprise Real Time 15 SP3 go1.17 Affected
SUSE Linux Enterprise Real Time 15 SP3 go1.18 Already fixed
SUSE Linux Enterprise Real Time 15 SP3 go1.18-openssl Released
SUSE Linux Enterprise Server 15 SP4 go1.17 Released
SUSE Linux Enterprise Server 15 SP4 go1.18 Already fixed
SUSE Linux Enterprise Server 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.17 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.18 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.18-openssl Released
SUSE Manager Proxy 4.2 go1.15 Not affected
SUSE Manager Proxy 4.2 go1.16 Not affected
SUSE Manager Proxy 4.2 go1.17 Released
SUSE Manager Proxy 4.2 go1.18 Released
SUSE Manager Proxy 4.2 go1.18-openssl Affected
SUSE Manager Proxy 4.3 go1.17 Released
SUSE Manager Proxy 4.3 go1.18 Already fixed
SUSE Manager Proxy 4.3 go1.18-openssl Released
SUSE Manager Retail Branch Server 4.2 go1.15 Not affected
SUSE Manager Retail Branch Server 4.2 go1.16 Not affected
SUSE Manager Retail Branch Server 4.2 go1.17 Released
SUSE Manager Retail Branch Server 4.2 go1.18 Released
SUSE Manager Retail Branch Server 4.2 go1.18-openssl Affected
SUSE Manager Retail Branch Server 4.3 go1.17 Released
SUSE Manager Retail Branch Server 4.3 go1.18 Already fixed
SUSE Manager Retail Branch Server 4.3 go1.18-openssl Released
SUSE Manager Server 4.2 go1.15 Not affected
SUSE Manager Server 4.2 go1.16 Not affected
SUSE Manager Server 4.2 go1.17 Released
SUSE Manager Server 4.2 go1.18 Released
SUSE Manager Server 4.2 go1.18-openssl Affected
SUSE Manager Server 4.3 go1.17 Released
SUSE Manager Server 4.3 go1.18 Already fixed
SUSE Manager Server 4.3 go1.18-openssl Released
openSUSE Leap 15.4 go1.18-openssl Released
openSUSE Leap 15.5 go1.18-openssl Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP1 go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 go1.16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 go1.17 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS go1.16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS go1.17 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS go1.16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS go1.17 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.17 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.18 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.17 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.18 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.18-openssl Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.15 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.17 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.18 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.18-openssl Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 go1.15 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.15 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.16 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.17 Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.15 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.16 Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.17 Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.18 Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise Server 15 SP1 go1.15 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS go1.15 Not affected
SUSE Linux Enterprise Server 15 SP2 go1.15 Not affected
SUSE Linux Enterprise Server 15 SP2 go1.16 Not affected
SUSE Linux Enterprise Server 15 SP2 go1.17 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS go1.15 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS go1.16 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS go1.17 Affected
SUSE Linux Enterprise Server 15 SP3 go1.15 Not affected
SUSE Linux Enterprise Server 15 SP3 go1.16 Not affected
SUSE Linux Enterprise Server 15 SP3 go1.17 Released
SUSE Linux Enterprise Server 15 SP3 go1.18 Released
SUSE Linux Enterprise Server 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise Server 15 SP3-LTSS go1.15 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS go1.16 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS go1.17 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS go1.18 Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS go1.18-openssl Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 go1.15 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 go1.15 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 go1.16 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 go1.17 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 go1.15 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 go1.15 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 go1.16 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 go1.17 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.15 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.16 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.17 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.18 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.18-openssl Released
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 go1.15 Not affected
SUSE Enterprise Storage 6 go1.15 Not affected
SUSE Linux Enterprise Desktop 15 SP1 go1.15 Not affected
SUSE Linux Enterprise Desktop 15 SP2 go1.15 Not affected
SUSE Linux Enterprise Desktop 15 SP2 go1.16 Not affected
SUSE Linux Enterprise Desktop 15 SP2 go1.17 Affected
SUSE Linux Enterprise Desktop 15 SP3 go1.15 Not affected
SUSE Linux Enterprise Desktop 15 SP3 go1.16 Not affected
SUSE Linux Enterprise Desktop 15 SP3 go1.17 Released
SUSE Linux Enterprise Desktop 15 SP3 go1.18 Released
SUSE Linux Enterprise Desktop 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise Real Time 15 SP2 go1.15 Not affected
SUSE Linux Enterprise Real Time 15 SP2 go1.16 Not affected
SUSE Linux Enterprise Real Time 15 SP2 go1.17 Released
SUSE Linux Enterprise Server 15 SP1-BCL go1.15 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL go1.15 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL go1.16 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL go1.17 Affected
SUSE Linux Enterprise Server 15 SP3-BCL go1.15 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL go1.16 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL go1.17 Affected
SUSE Linux Enterprise Server 15 SP3-BCL go1.18 Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL go1.18-openssl Affected
SUSE Manager Proxy 4.0 go1.15 Not affected
SUSE Manager Proxy 4.1 go1.15 Not affected
SUSE Manager Proxy 4.1 go1.16 Not affected
SUSE Manager Proxy 4.1 go1.17 Affected
SUSE Manager Retail Branch Server 4.0 go1.15 Not affected
SUSE Manager Retail Branch Server 4.1 go1.15 Not affected
SUSE Manager Retail Branch Server 4.1 go1.16 Not affected
SUSE Manager Retail Branch Server 4.1 go1.17 Affected
SUSE Manager Server 4.0 go1.15 Not affected
SUSE Manager Server 4.1 go1.15 Not affected
SUSE Manager Server 4.1 go1.16 Not affected
SUSE Manager Server 4.1 go1.17 Affected
Container Status
bci/golang:1.16
trento/trento-runner
go1.16Not affected
bci/golang:1.17 go1.17Released
bci/golang
bci/golang:1.18
go1.18Already fixed


SUSE Timeline for this CVE

CVE page created: Wed Apr 13 06:15:09 2022
CVE page last modified: Tue May 30 13:05:21 2023