Upstream information

CVE-2022-23630 at MITRE

Description

Gradle is a build tool with a focus on build automation and support for multi-language development. In some cases, Gradle may skip that verification and accept a dependency that would otherwise fail the build as an untrusted external artifact. This occurs when dependency verification is disabled on one or more configurations and those configurations have common dependencies with other configurations that have dependency verification enabled. If the configuration that has dependency verification disabled is resolved first, Gradle does not verify the common dependencies for the configuration that has dependency verification enabled. Gradle 7.4 fixes that issue by validating artifacts at least once if they are present in a resolved configuration that has dependency verification active. For users who cannot update either do not use `ResolutionStrategy.disableDependencyVerification()` and do not use plugins that use that method to disable dependency verification for a single configuration or make sure resolution of configuration that disable that feature do not happen in builds that resolve configuration where the feature is enabled.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.4
Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity High High
Privileges Required Low High
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1196068 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Enterprise Storage 7 gradle Not affected
SUSE Linux Enterprise Desktop 15 SP3 gradle Not affected
SUSE Linux Enterprise Desktop 15 SP4 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 gradle Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gradle Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 gradle Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 gradle Not affected
SUSE Linux Enterprise Real Time 15 SP2 gradle Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS gradle Not affected
SUSE Linux Enterprise Server 15 SP3 gradle Not affected
SUSE Linux Enterprise Server 15 SP4 gradle Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 gradle Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gradle Not affected
SUSE Linux Enterprise Storage 7.1 gradle Not affected
SUSE Manager Proxy 4.1 gradle Not affected
SUSE Manager Proxy 4.2 gradle Not affected
SUSE Manager Proxy 4.3 gradle Not affected
SUSE Manager Retail Branch Server 4.1 gradle Not affected
SUSE Manager Retail Branch Server 4.2 gradle Not affected
SUSE Manager Retail Branch Server 4.3 gradle Not affected
SUSE Manager Server 4.1 gradle Not affected
SUSE Manager Server 4.2 gradle Not affected
SUSE Manager Server 4.3 gradle Not affected