Upstream information

CVE-2022-23613 at MITRE

Description

xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1195678 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libpainter0 >= 0.9.19-1.1
  • librfxencode0 >= 0.9.19-1.1
  • xrdp >= 0.9.19-1.1
  • xrdp-devel >= 0.9.19-1.1
Patchnames:
openSUSE Tumbleweed GA libpainter0-0.9.19-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 xrdp Not affected
SUSE CaaS Platform 4.0 xrdp Not affected
SUSE Enterprise Storage 6 xrdp Not affected
SUSE Enterprise Storage 7 xrdp Not affected
SUSE Linux Enterprise Desktop 15 SP3 xrdp Not affected
SUSE Linux Enterprise Desktop 15 SP4 xrdp Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 xrdp Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 xrdp Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 xrdp Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 xrdp Not affected
SUSE Linux Enterprise Real Time 15 SP2 xrdp Not affected
SUSE Linux Enterprise Server 12 SP2 BCL xrdp Not affected
SUSE Linux Enterprise Server 12 SP3 BCL xrdp Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS xrdp Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS xrdp Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS xrdp Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS xrdp Not affected
SUSE Linux Enterprise Server 12 SP5 xrdp Not affected
SUSE Linux Enterprise Server 15 ESPOS xrdp Not affected
SUSE Linux Enterprise Server 15 LTSS xrdp Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS xrdp Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS xrdp Not affected
SUSE Linux Enterprise Server 15 SP3 xrdp Not affected
SUSE Linux Enterprise Server 15 SP4 xrdp Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 xrdp Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 xrdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 xrdp Not affected
SUSE Linux Enterprise Storage 7.1 xrdp Not affected
SUSE Manager Proxy 4.1 xrdp Not affected
SUSE Manager Proxy 4.2 xrdp Not affected
SUSE Manager Proxy 4.3 xrdp Not affected
SUSE Manager Retail Branch Server 4.1 xrdp Not affected
SUSE Manager Retail Branch Server 4.2 xrdp Not affected
SUSE Manager Retail Branch Server 4.3 xrdp Not affected
SUSE Manager Server 4.1 xrdp Not affected
SUSE Manager Server 4.2 xrdp Not affected
SUSE Manager Server 4.3 xrdp Not affected
SUSE OpenStack Cloud 8 xrdp Not affected
SUSE OpenStack Cloud 9 xrdp Not affected
SUSE OpenStack Cloud Crowbar 8 xrdp Not affected
SUSE OpenStack Cloud Crowbar 9 xrdp Not affected