Upstream information

CVE-2021-41816 at MITRE

Description

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1193080 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • libruby2_7-2_7 >= 2.7.5-1.1
  • libruby3_0-3_0 >= 3.0.3-1.1
  • libruby3_1-3_1 >= 3.1.0-1.1
  • ruby2.7 >= 2.7.5-1.1
  • ruby2.7-devel >= 2.7.5-1.1
  • ruby2.7-devel-extra >= 2.7.5-1.1
  • ruby2.7-doc >= 2.7.5-1.1
  • ruby2.7-doc-ri >= 2.7.5-1.1
  • ruby3.0 >= 3.0.3-1.1
  • ruby3.0-devel >= 3.0.3-1.1
  • ruby3.0-devel-extra >= 3.0.3-1.1
  • ruby3.0-doc >= 3.0.3-1.1
  • ruby3.0-doc-ri >= 3.0.3-1.1
  • ruby3.1 >= 3.1.0-1.1
  • ruby3.1-devel >= 3.1.0-1.1
  • ruby3.1-devel-extra >= 3.1.0-1.1
  • ruby3.1-doc >= 3.1.0-1.1
  • ruby3.1-doc-ri >= 3.1.0-1.1
Patchnames:
openSUSE Tumbleweed GA libruby2_7-2_7-2.7.5-1.1
openSUSE Tumbleweed GA libruby3_0-3_0-3.0.3-1.1
openSUSE Tumbleweed GA libruby3_1-3_1-3.1.0-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 ruby Ignore
HPE Helion OpenStack 8 ruby2.1 Not affected
SLES15-EC2-CHOST-HVM-BYOS ruby2.5 Not affected
SLES15-SP1-CHOST-BYOS-Azure ruby2.5 Not affected
SLES15-SP1-CHOST-BYOS-EC2 ruby2.5 Not affected
SLES15-SP1-CHOST-BYOS-GCE ruby2.5 Not affected
SLES15-SP2-CHOST-BYOS-Aliyun ruby2.5 Not affected
SLES15-SP2-CHOST-BYOS-Azure ruby2.5 Not affected
SLES15-SP2-CHOST-BYOS-EC2 ruby2.5 Not affected
SLES15-SP2-CHOST-BYOS-GCE ruby2.5 Not affected
SLES15-SP3-CHOST-BYOS-Aliyun ruby2.5 Not affected
SLES15-SP3-CHOST-BYOS-Azure ruby2.5 Not affected
SLES15-SP3-CHOST-BYOS-EC2 ruby2.5 Not affected
SLES15-SP3-CHOST-BYOS-GCE ruby2.5 Not affected
SUSE CaaS Platform 4.0 ruby Ignore
SUSE CaaS Platform 4.0 ruby2.5 Not affected
SUSE Enterprise Storage 6 ruby Ignore
SUSE Enterprise Storage 6 ruby2.5 Not affected
SUSE Linux Enterprise Desktop 15 SP2 ruby Ignore
SUSE Linux Enterprise Desktop 15 SP2 ruby2.5 Not affected
SUSE Linux Enterprise Desktop 15 SP3 ruby Ignore
SUSE Linux Enterprise Desktop 15 SP3 ruby2.5 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ruby Ignore
SUSE Linux Enterprise High Performance Computing 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS ruby Ignore
SUSE Linux Enterprise High Performance Computing 15 LTSS ruby2.5 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS ruby Ignore
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS ruby2.5 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ruby Ignore
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS ruby2.5 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ruby Ignore
SUSE Linux Enterprise High Performance Computing 15 SP2 ruby2.5 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 ruby Ignore
SUSE Linux Enterprise High Performance Computing 15 SP3 ruby2.5 Not affected
SUSE Linux Enterprise Micro 5.0 ruby2.5 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 ruby Ignore
SUSE Linux Enterprise Module for Basesystem 15 SP2 ruby2.5 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 ruby Ignore
SUSE Linux Enterprise Module for Basesystem 15 SP3 ruby2.5 Not affected
SUSE Linux Enterprise Server 11 SP1 ruby Not affected
SUSE Linux Enterprise Server 11 SP3 ruby Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS ruby Not affected
SUSE Linux Enterprise Server 12 SP2 BCL ruby Ignore
SUSE Linux Enterprise Server 12 SP2 BCL ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP3 BCL ruby Ignore
SUSE Linux Enterprise Server 12 SP3 BCL ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS ruby Ignore
SUSE Linux Enterprise Server 12 SP3 ESPOS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS ruby Ignore
SUSE Linux Enterprise Server 12 SP3 LTSS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS ruby Ignore
SUSE Linux Enterprise Server 12 SP4 ESPOS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS ruby Ignore
SUSE Linux Enterprise Server 12 SP4 LTSS ruby2.1 Not affected
SUSE Linux Enterprise Server 12 SP5 ruby Ignore
SUSE Linux Enterprise Server 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise Server 15 ESPOS ruby Ignore
SUSE Linux Enterprise Server 15 ESPOS ruby2.5 Not affected
SUSE Linux Enterprise Server 15 LTSS ruby Ignore
SUSE Linux Enterprise Server 15 LTSS ruby2.5 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS ruby Ignore
SUSE Linux Enterprise Server 15 SP1 LTSS ruby2.5 Not affected
SUSE Linux Enterprise Server 15 SP2 ruby Ignore
SUSE Linux Enterprise Server 15 SP2 ruby2.5 Not affected
SUSE Linux Enterprise Server 15 SP3 ruby Ignore
SUSE Linux Enterprise Server 15 SP3 ruby2.5 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ruby Ignore
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ruby2.5 Not affected
SUSE Linux Enterprise Server for SAP All-in-One 11 SP4 ruby Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ruby2.1 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 15 ruby2.5 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ruby2.5 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ruby2.5 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ruby Ignore
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ruby2.5 Not affected
SUSE Linux Enterprise Storage 7 ruby Ignore
SUSE Linux Enterprise Storage 7 ruby2.5 Not affected
SUSE Linux Enterprise Storage 7.1 ruby Ignore
SUSE Linux Enterprise Storage 7.1 ruby2.5 Not affected
SUSE Manager Proxy 4.1 ruby Ignore
SUSE Manager Proxy 4.1 ruby2.5 Not affected
SUSE Manager Proxy 4.2 ruby Ignore
SUSE Manager Proxy 4.2 ruby2.5 Not affected
SUSE Manager Retail Branch Server 4.1 ruby Ignore
SUSE Manager Retail Branch Server 4.1 ruby2.5 Not affected
SUSE Manager Retail Branch Server 4.2 ruby Ignore
SUSE Manager Retail Branch Server 4.2 ruby2.5 Not affected
SUSE Manager Server 4.1 ruby Ignore
SUSE Manager Server 4.1 ruby2.5 Not affected
SUSE Manager Server 4.2 ruby Ignore
SUSE Manager Server 4.2 ruby2.5 Not affected
SUSE OpenStack Cloud 8 ruby Ignore
SUSE OpenStack Cloud 8 ruby2.1 Not affected
SUSE OpenStack Cloud 9 ruby Ignore
SUSE OpenStack Cloud 9 ruby2.1 Not affected
SUSE OpenStack Cloud Crowbar 8 ruby Ignore
SUSE OpenStack Cloud Crowbar 8 ruby2.1 Not affected
SUSE OpenStack Cloud Crowbar 9 ruby Ignore
SUSE OpenStack Cloud Crowbar 9 ruby2.1 Not affected
bci/ruby
suse/rmt-server
suse/rmt-server:2.7
ruby2.5Not affected